Bug 69825

Summary: Partitioning error: cannot import name Main Bootloader Window
Product: [Retired] Red Hat Public Beta Reporter: Jim Wiedman <jim>
Component: anacondaAssignee: Michael Fulbright <msf>
Status: CLOSED NOTABUG QA Contact: Brock Organ <borgan>
Severity: high Docs Contact:
Priority: medium    
Version: limbo   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-07-30 20:18:26 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 67217    

Description Jim Wiedman 2002-07-25 19:31:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc2)
Gecko/20020618 Netscape/7.0b1

Description of problem:
When clicking next after setting up the partition table, an unhandled exception
is reported.  I am trying to keep an ext2 partition during a new install, that
could be the problem.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Choose Partition with DiskDruid during the install.
2. Delete most existing partitions and add an LVM.
3.  Click next.

Actual Results:  I get an error message, then the system reboots.

Expected Results:  A new partition table with an LVM should be created.

Additional info:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 552, in next Clicked
  File "/usr/lib/anaconda/gui.py", line 704, in setScreen
     exec s
  File "<string>", line 1, in ?
ImportError:  cannot import name MainBootloaderWindow

Comment 1 Michael Fulbright 2002-07-30 19:15:13 UTC
Is this a CD based install?

Have you run the mediacheck?

Comment 2 Jim Wiedman 2002-07-30 19:19:22 UTC
Yes, it was a CD based install and I did run the CD check.  When I completely
deleted all partitions and started again, it worked just fine.  I haven't tried
to partition with a preexisting ext2 now that the latest beta has been released,
but I will try to reproduce the error.

Comment 3 Jim Wiedman 2002-07-30 19:58:32 UTC
I reinstalled RedHat 7.1, then installed the latest beta version keeping the 7.1
version intact (adding an LVM and ext3 partitions).  The error was not
reproduced.  I don't know if the problem was fixed with the most recent beta, or
if there was something wrong with my partition table or original install disk.

Comment 4 Jim Wiedman 2002-07-30 20:18:20 UTC
I just tried to load Limbo again (leaving the 7.1 install).  This time, unlike
the second time I tried, I deleted old partitions in DiskDruid (but not all the
partitions) and created new ones including an LVM.  

Another exception occured.  The message is:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 613, in nextClicked
  File "/usr/lib/anaconda/gui.py", line 779, in setScreen
    exec s
  File "<string>", line 1, in ?
ImportError: cannot import name MainBootloaderWindow

Comment 5 Michael Fulbright 2002-08-14 05:43:36 UTC
This is almost certainly CDs which are marginal so they work sometimes and dont
other times.

Comment 6 Jim Wiedman 2002-08-14 13:15:25 UTC
If this is a poor CD creation:

1)  The disk check utility is not working because it reports all my
         CDs in good working order.
2)  Two different CD burners created bad disks where the only problem
         created was with the partitioning program.