Bug 72036

Summary: rhn-push provides misleading error message
Product: Red Hat Satellite 5 Reporter: Matt Jamison <jamisonm>
Component: ServerAssignee: Mihai Ibanescu <mihai.ibanescu>
Status: CLOSED CURRENTRELEASE QA Contact: Fanny Augustin <fmoquete>
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: alikins, bretm, cturner, gafton, mihai.ibanescu, robin.norwood, taw
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-08-23 16:22:26 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Josef Komenda 2002-08-20 20:26:23 UTC
Description of Problem: rhn-push provides misleading error message when the
channel you are uploading does not exist (due to typo, etc...). It currently
gives a 'Permission Denied' error. Should be something a tad more descriptive.


Version-Release number of selected component (if applicable): see bug 63780

Comment 1 Mihai Ibanescu 2002-08-22 14:56:30 UTC
Hmm. When I pass an arbitrary channel I see:

Error Message:
    You are not allowed to perform administrative tasks on the channel
sdfklgsdfgsdfgsdfg
Error Class Code: 4
Error Class Info: Permission denied.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please submit a bug report to rhn-help@redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.


The channel may be there and you are not allowed to edit it, or it may not be
there at all; FWIW, I consider it the same case. Is that wrong?

Comment 2 Josef Komenda 2002-08-22 16:56:04 UTC
The problem was encountered when a user made a typo on the channel name, and
received the 'Permission denied' error. I think it would be helpful to
differentiate between 'You aren't allowed to' and 'I can't find the channel you
asked for'. (If that's possible)


Comment 3 Mihai Ibanescu 2002-08-22 22:36:27 UTC
gdk suggested the differentiation would be dangerous.
Changed to:

Insufficient privileges or channel %s does not exist
Channel error

Comment 4 Josef Komenda 2002-08-23 17:59:55 UTC
Fixed in latest version, Closing.