Bug 7493

Summary: libtool package provides source but no compiled library
Product: [Retired] Red Hat Linux Reporter: jfm3 <jfm3>
Component: libtoolAssignee: Jakub Jelinek <jakub>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-12-22 16:33:12 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description jfm3 1999-12-01 20:37:38 UTC
OK, maybe there's a reason but I don't know it.

The libtool package that comes with redhat simply dumps a bunch of sources
in your share directory, but no compiled libraries.

As a result, the build process for an Open Source project I'm helping with
(http://www.quasimodo.org) is butt-ugly.

Why is there no libltdl.* in the libtool rpm?

(jfm3)

Comment 1 Jeff Johnson 1999-12-02 14:38:59 UTC
Adding the library to libtool would necessitate changing libtool from a noarch
to a per-arch package. So far, there is no Red Hat package that needs the
functionality supplied by the libtool libraries. Can you supply some more
details regarding why the libtool libraries have to be included? Meanwhile,
it's pretty trivial to make an arch-specific libtool package including the
libraries if that simplifies your project.

Comment 2 Jeff Johnson 1999-12-22 16:33:59 UTC
Fixed in libtool-1.3.3-2 in Raw Hide.