Bug 79814

Summary: postgresql-pl should obsolete postgresql-perl
Product: [Retired] Red Hat Raw Hide Reporter: Enrico Scholz <rh-bugzilla>
Component: postgresqlAssignee: Andrew Overholt <overholt>
Status: CLOSED RAWHIDE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-04-16 18:59:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 79579    

Description Enrico Scholz 2002-12-17 01:53:39 UTC
Description of problem:

The new postgresql-pl package of postgresql-7.3 should obsolete postgresql-perl.
Else, upgrade fails because of conflicting files:

| $ rpm -Uvh postgresql-pl-7.3-2.i386.rpm
| Preparing...                ########################################### [100%]
|         file /usr/lib/pgsql/plperl.so from install of postgresql-pl-7.3-2
conflicts with file from package postgresql-perl-7.2.2-1


Version-Release number of selected component (if applicable):

postgresql-pl-7.3-2

Comment 1 Andrew Overholt 2003-03-04 17:37:46 UTC
Assigning to me.

Comment 2 Andrew Overholt 2003-04-16 18:59:52 UTC
This is now fixed in the packages which will be included in rawhide.

Comment 3 David Kaplan 2003-11-18 00:17:31 UTC
If you obsolete postgresql-perl, what happens to the functionality
that was contained in the the Pg.pm perl module?