Bug 79876

Summary: rhn_check: Error refreshing package list (code 20)
Product: Red Hat Enterprise Linux 4 Reporter: Bob Gorman <bob>
Component: up2dateAssignee: Adrian Likins <alikins>
Status: CLOSED RAWHIDE QA Contact: Red Hat Satellite QA List <satellite-qa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.0CC: cturner, gafton, mihai.ibanescu, pjones, sean, taw
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-08-27 00:26:53 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Bob Gorman 2002-12-17 18:57:48 UTC
Description of problem:

Trying to use rhn_check to refresh the package list at RHN for system (sid=1001662560) fails.

Version-Release number of selected component (if applicable):

RH 8.0
up2date-3.0.7-1

How reproducible:

Very

Steps to Reproduce:
1. Schedule a package list refresh at RHN
2. Run rhn_check -v on client system
3.
    
Actual results:

rhn_check reports: ERROR: refreshing remote package list for System Profile
RHN web app reports: Client execution returned code 20 (Error refreshing package list)


Expected results:

Client execution returned code 0 (rpmlist refreshed)

Help.



Additional info:

Comment 1 Adrian Likins 2003-01-15 05:12:06 UTC
This should be fixed in a hopefully soon to be released errata.
Versions of 3.0.40 or higher include a fix

Comment 2 Sean Sosik-Hamor 2003-03-27 16:09:12 UTC
I get the same error for all of the RedHat 8.0 systems I manage however I've
found a temporary workaround.  If I run up2date -p after manually installing new
RPMs it will update the package list in my RedHat Network account.