Bug 8131

Summary: setxkbmap dislikes xf86config's configurations
Product: [Retired] Red Hat Linux Reporter: David Baron <dbaron>
Component: XFree86Assignee: Preston Brown <pbrown>
Status: CLOSED WONTFIX QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-03 21:32:41 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description David Baron 2000-01-03 05:21:59 UTC
Using a configuration generated by xf86config, setxkbmap gives an error
every time it is run that is something like (I don't want to go back to my
old configuration right now, but this is based on my memory, enhanced by
'strings `which setxkbmap`'):

  Couldn't interpret _XKB_RULES_NAMES property

The problem seems to be that xf86config generates a line at the end of the
keyboard section like:

      XkbKeymap   "xfree86(us)"

whereas Xconfigurator, in that same place, generates:

     XkbKeycodes     "xfree86"
     XkbTypes        "default"
     XkbCompat       "default"
     XkbSymbols      "us(pc101)"
     XkbGeometry     "pc"
     XkbRules        "xfree86"
     XkbModel        "pc101"
      XkbLayout       "us"

setxkbmap works like a charm when I change the first line (as generated by
xf86config) to the above 8 (as generated by Xconfigurator).

Comment 1 Preston Brown 2000-02-03 21:32:59 UTC
don't use xf86config.  We don't support it.