Bug 83682

Summary: kudzu reports a floppy even though there isn't one
Product: [Retired] Red Hat Linux Reporter: Brent Fox <bfox>
Component: hwbrowserAssignee: Brent Fox <bfox>
Status: CLOSED RAWHIDE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-05-25 14:29:43 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Brent Fox 2003-02-07 01:13:28 UTC
Find a machine with no floppy drive like a laptop or a legacy free system. 
Doing a kudzu probe returns a floppy device.  Why?  Is this a kernel thing?  May
be related to bug #71036.

Comment 1 Bill Nottingham 2003-02-07 06:18:22 UTC
Usually, it's because there is a floppy controller and therefore a
bios-configured drive even if it's not present.

Are you getting the error messages from 71036? Or is it finding a 'detached'
floppy drive?

Comment 2 Brent Fox 2003-02-07 06:23:24 UTC
No, I'm not seeing any error messages but I was wondering if having a floppy
device was hard wired into the kernel.

The main problem I have is that hwbrowser shows that the system has a floppy
when there isn't one.  Is there some way to work around that?

Comment 3 Bill Nottingham 2003-02-07 06:25:16 UTC
You can grey out or not show devices that have the 'detached' property set to 1.

Comment 4 Brent Fox 2003-02-07 06:33:30 UTC
Oh, ok.  I'll try that.  We can close this bug then.

Comment 5 Brent Fox 2003-02-07 06:36:22 UTC
Actually, I'll assign it to hwbrowser so I remember to do this tomorrow.

Comment 6 Brent Fox 2003-02-08 00:15:13 UTC
Ok, should be fixed in hwbrowser-0.8-8.  When the 'detached' property on a
floppy is set to 1, hwbrowser should now hide all the lower widgets and print
"No floppy drives detected" in the upper device list.  QA, please verify.

Comment 7 Brent Fox 2003-05-25 14:29:43 UTC
There is a stack of 64 bugs that have been in Modified state for a long period
of time.  I am closing these as Rawhide now.  If you find that the issue is not
fixed, please reopen this report.