Bug 8809

Summary: RPM dies with fatal err on alpha
Product: [Retired] Red Hat Linux Reporter: Kelly Cox <kaycee>
Component: gnorpmAssignee: Matt Wilson <msw>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1CC: kaycee
Target Milestone: ---   
Target Release: ---   
Hardware: alpha   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-08-22 14:17:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Kelly Cox 2000-01-24 20:56:40 UTC
when trying to install anything RPM dies with fatal error, floating point
exception.

i tried to install an editor..
then xclock...
then xfrisk...
3 out of 3, same error.  it is a new install on a 64MB alphastation 200.
it is out of the box vanilla install. i'm new to linux and red hat.

Comment 1 Jeff Johnson 2000-01-24 21:36:59 UTC
What does "file /bin/rpm" say?

What do "rpm --version" and "rpm -qa" say?

How are you trying to install packages (literal text please)?

Comment 2 Kelly Cox 2000-01-25 19:11:59 UTC
RPM failed using GNOME RPM, trying rpm from the command line worked.
I have also tried using GNOME RPM with the GNU compilers and libraries, it
still fails with the same error...floating point exception.

file /bin/rpm says: ELF 64-bit LSB executable, ALPHA(unofficial), version 1
statically linked, stripped

rpm -version says 3.0.3

rpm -qa lists loads of stuff, but the not the stuff i tried to load, until
i used the command line version of RPM.

Comment 3 Jeff Johnson 2000-01-31 16:15:59 UTC
Try gnorpm-0.9-12 and rpm-*-3.0.4-0.36 from Raw Hide, there is at least one bug
fixed in those packages that may be relevant to your problem.

Changing component to gnorpm ...

Comment 4 Elliot Lee 2000-02-03 20:32:59 UTC
Probably an indication that -mieee needs to be added to the default
rpm_opt_flags on the alpha - without it, lots of programs that work on other
architectures will go boom on the alpha.

Comment 5 Bill Nottingham 2000-02-05 19:40:59 UTC
*** Bug 8737 has been marked as a duplicate of this bug. ***

Comment 6 Elliot Lee 2000-02-14 22:15:59 UTC
I bet this is also a problem with not having -mieee on the Alpha CFLAGS :)

Comment 7 Alan Cox 2000-08-22 14:17:55 UTC
Was this fixed ???