Bug 886020

Summary: Anaconda doesn't warn when existing raw partition is used for / without creating new file system
Product: Red Hat Enterprise Linux 6 Reporter: Jan Stodola <jstodola>
Component: anacondaAssignee: Samantha N. Bueno <sbueno>
Status: CLOSED ERRATA QA Contact: Release Test Team <release-test-team>
Severity: medium Docs Contact:
Priority: medium    
Version: 6.4CC: lkardos, pbokoc
Target Milestone: rcKeywords: Reopened
Target Release: ---   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: anaconda-13.21.203-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-11-21 09:56:55 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 960065, 841211    

Description Jan Stodola 2012-12-11 10:30:17 UTC
Description of problem:
Warning dialog is not shown when user uses raw partition for / mount point and doesn't create new file system on it.

Version-Release number of selected component (if applicable):
anaconda-13.21.187-1.el6

How reproducible:
always

Steps to Reproduce:
1. install system where /boot, / and swap are raw partitions
2. start new installation in graphical mode
3. when asked, select "Fresh Installation"
4. proceed to custom partitioning
5. reuse partition for /boot from previous install, create new file system (check "Format as:")
6. reuse partition for / from previous install, make sure that "Format as:" is unchecked and click "OK"
  
Actual results:
There is no warning that formatting has not been selected for / partition

Expected results:
User is warned when reusing / from previous installation and formatting of the partition has not been selected.

Additional info:
I'm only able to reproduce then reusing raw partition for /. When reusing / on LVM, anaconda correctly shows warning dialog.

Comment 6 RHEL Product and Program Management 2013-05-06 21:14:21 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 11 Samantha N. Bueno 2013-08-07 18:35:09 UTC
I followed the steps to reproduce, but this isn't happening when I test with the latest 6.5 nightly. I see the warning message as I would expect to.

Comment 13 Samantha N. Bueno 2013-08-13 15:11:46 UTC
Thanks for re-opening, Jan; I was able to reproduce this after my initial comment. Patch posted for review.

Comment 14 Samantha N. Bueno 2013-08-13 17:38:58 UTC
Patch pushed, commit 29f2cff3ea3454af48a0bef35f4fd685a4bf61b3 on rhel6-branch.

Comment 16 Ľuboš Kardoš 2013-08-30 10:31:10 UTC
Verified on RHEL6.5-20130820.2 anaconda 13.21.203

Comment 18 errata-xmlrpc 2013-11-21 09:56:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1588.html