Bug 964012

Summary: Trying to use bumblebee fails with NOUVEAU(0): [drm] failed to set drm interface version.
Product: [Fedora] Fedora Reporter: Ankur Sinha (FranciscoD) <sanjay.ankur>
Component: xorg-x11-serverAssignee: X/OpenGL Maintenance List <xgl-maint>
Status: CLOSED EOL QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 19CC: daramas444, gianluca.cecchi, gsgatlin, isaac, javiertury, mail, mnl, mszpak, robert, romainguinot, tod.jackson, xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-02-17 15:15:29 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Xorg.8.log
none
Xorg log
none
xorg.8.log
none
dmesg output none

Description Ankur Sinha (FranciscoD) 2013-05-17 04:06:41 UTC
Created attachment 749165 [details]
Xorg.8.log

Description of problem:
While trying to run bumblebee to make use of my nvidia card, X fails with the following error:

NOUVEAU(0): [drm] failed to set drm interface version.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.14.1-2.fc19.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Set up bumbleebee as per https://fedoraproject.org/wiki/Bumblebee (F19 isn't  mentioned but packages are available)
2. optirun <command>
3.
  
Actual results:
Doesn't work. 

Expected results:
Should work

Additional info:
[ankur@ankur-pc  20130430_phd_application_cover_letter(master *)]$ optirun -vv 0ad
[89459.587854] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[89459.588220] [INFO]Configured driver: nouveau
[89459.590583] [DEBUG]optirun version 3.2.1 starting...
[89459.590604] [DEBUG]Active configuration:
[89459.590612] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[89459.590620] [DEBUG] X display: :8
[89459.590628] [DEBUG] LD_LIBRARY_PATH:
[89459.590635] [DEBUG] Socket path: /var/run/bumblebee.socket
[89459.590643] [DEBUG] Accel/display bridge: auto
[89459.590651] [DEBUG] VGL Compression: proxy
[89459.590658] [DEBUG] VGLrun extra options:
[89459.590666] [DEBUG] Primus LD Path: /usr/lib/primus:/usr/lib64/primus
[89459.590722] [DEBUG]Using auto-detected bridge virtualgl
[89459.960659] [INFO]Response: No - error: [XORG] (EE) NOUVEAU(0): [drm] failed to set drm interface version.

[89459.960697] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NOUVEAU(0): [drm] failed to set drm interface version.

[89459.960715] [DEBUG]Socket closed.
[89459.960752] [ERROR]Aborting because fallback start is disabled.
[89459.960771] [DEBUG]Killing all remaining processes.
[ankur@ankur-pc  20130430_phd_application_cover_letter(master *)]$

Xorg.log attached.

A similar issue is reported here, and bumblebee upstream concluded it wasn't a bumbleebee bug:

https://github.com/Bumblebee-Project/Bumblebee/issues/291

Comment 1 daramas444 2013-07-09 09:45:27 UTC
Created attachment 770880 [details]
Xorg log

Comment 2 daramas444 2013-07-09 09:46:03 UTC
I can confirm this.

Description of problem:
While trying to run bumblebee to make use of my nvidia card on a Asus X73SV, X fails with the following error:

NOUVEAU(0): [drm] failed to set drm interface version.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.14.1-4.fc19.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Set up bumbleebee as per https://fedoraproject.org/wiki/Bumblebee (F19 isn't  mentioned but packages are available)
2. optirun <command>
  
Actual results:
Doesn't work. 

Expected results:
Should work

Additional info:
[edouard@EDStation]/etc/X11% optirun -vv dolphin                          
[ 9556.240278] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[ 9556.240495] [INFO]Configured driver: nouveau
[ 9556.241286] [DEBUG]optirun version 3.2.1 starting...
[ 9556.241295] [DEBUG]Active configuration:
[ 9556.241298] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[ 9556.241301] [DEBUG] X display: :8
[ 9556.241304] [DEBUG] LD_LIBRARY_PATH: 
[ 9556.241306] [DEBUG] Socket path: /var/run/bumblebee.socket
[ 9556.241309] [DEBUG] Accel/display bridge: auto
[ 9556.241312] [DEBUG] VGL Compression: proxy
[ 9556.241315] [DEBUG] VGLrun extra options: 
[ 9556.241317] [DEBUG] Primus LD Path: /usr/lib/primus:/usr/lib64/primus
[ 9556.241338] [DEBUG]Using auto-detected bridge virtualgl
[ 9556.501983] [INFO]Response: No - error: [XORG] (EE) NOUVEAU(0): [drm] failed to set drm interface version.

[ 9556.502012] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NOUVEAU(0): [drm] failed to set drm interface version.

[ 9556.502019] [DEBUG]Socket closed.
[ 9556.502034] [ERROR]Aborting because fallback start is disabled.
[ 9556.502041] [DEBUG]Killing all remaining processes.

Xorg.log attached.

Comment 3 romainguinot 2013-07-14 16:57:16 UTC
I face the same issue on F19 upgraded from F18, with the nouveau driver

error is the same : 

NOUVEAU(0): [drm] failed to set drm interface version.

on Dell E6530 with NVIDIA NVS 5200M (GDDR5 1GB) Discrete Graphics, packages :

xorg-x11-server-Xorg-1.14.2-4.fc19.x86_64
xorg-x11-drv-nouveau-1.0.7-1.fc19.x86_64
bumblebee-3.2.1-1.fc19.x86_64
kernel 3.9.9-302.fc19.x86_64

If you require more information, let me know.

I did not try bumblebee in F18 so i can't say if it was working before. decided to give it a go in F19.

Comment 4 daramas444 2013-07-16 06:49:59 UTC
The problem persists with 
kernel 3.9.9-302.fc19.x86_64
xorg-x11-server-Xorg 1.14.2-4.fc19

Comment 5 Gianluca Cecchi 2013-07-23 16:01:10 UTC
The same for me with an Asus U36SD laptop where nouveau worked with Fedora 17 and optimus.

I see this output related to card detection in /var/log/Xorg.8.log

...
[ 30179.749] (--) PCI:*(0:1:0:0) 10de:1050:1043:1682 rev 161, Mem @ 0xdb000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000d000/128, BIOS @ 0x????????/524288
...

strange the "BIOS @ 0x????????"
other lines
[ 30179.807] (II) [drm] nouveau interface version: 1.1.0
[ 30179.807] (II) Loading sub module "dri"
[ 30179.807] (II) LoadModule: "dri"
[ 30179.807] (II) Module "dri" already built-in
[ 30179.808] (II) NOUVEAU(0): Loaded DRI module
[ 30179.866] (EE) NOUVEAU(0): [drm] failed to set drm interface version.
[ 30179.866] (EE) NOUVEAU(0): [drm] error opening the drm
[ 30179.866] (EE) NOUVEAU(0): 820: 
[ 30179.866] (II) UnloadModule: "nouveau"
[ 30179.866] (EE) Screen(s) found, but none have a usable configuration.
[ 30179.866] (EE) 
Fatal server error:
[ 30179.866] (EE) no screens found(EE) 
[ 30179.866] (EE) 

Full log attached.

Currently
[g.cecchi@ope46 ~]$ uname -r
3.9.9-302.fc19.x86_64

[g.cecchi@ope46 ~]$ rpm -q xorg-x11-drv-nouveau 
xorg-x11-drv-nouveau-1.0.7-1.fc19.x86_64

[g.cecchi@ope46 ~]$ rpm -q xorg-x11-server-Xorg 
xorg-x11-server-Xorg-1.14.2-5.fc19.x86_64

Gianluca

Comment 6 Gianluca Cecchi 2013-07-23 16:02:12 UTC
Created attachment 777374 [details]
xorg.8.log

Comment 7 Gianluca Cecchi 2013-07-23 16:02:54 UTC
Created attachment 777376 [details]
dmesg output

output of dmesg

Comment 8 daramas444 2013-07-25 10:03:24 UTC
same behaviour with bumblebee 3.2.1 revision 2

Comment 9 daramas444 2013-08-04 08:13:47 UTC
last update didnt solve it.

also here is additional info:

[root@EDStation ~]# systemctl status bumblebeed.service 
bumblebeed.service - Bumblebee C Daemon                                                                                                                                                              
   Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled)                                                                                                                              
   Active: active (running) since dim. 2013-08-04 09:51:22 CEST; 20min ago                                                                                                                           
 Main PID: 582 (bumblebeed)                                                                                                                                                                          
   CGroup: name=systemd:/system/bumblebeed.service                                                                                                                                                   
           └─582 /usr/sbin/bumblebeed                                                                                                                                                                
                                                                                                                                                                                                     
août 04 10:11:59 EDStation.localdomain bumblebeed[582]: [ 1257.728395] [ERROR][XORG] (EE) NOUVEAU(0): [drm] error opening the drm                                                                    
août 04 10:11:59 EDStation.localdomain bumblebeed[582]: [ 1257.728399] [ERROR][XORG] (EE) NOUVEAU(0): 835:                                                                                           
août 04 10:11:59 EDStation.localdomain bumblebeed[582]: [ 1257.728403] [ERROR][XORG] (EE) Screen(s) found, but none have a usable configuration.                                                     
août 04 10:11:59 EDStation.localdomain bumblebeed[582]: [ 1257.728406] [ERROR][XORG] (EE)                                                                                                            
août 04 10:11:59 EDStation.localdomain bumblebeed[582]: [ 1257.728409] [ERROR][XORG] (EE) no screens found(EE)                                                                                       
août 04 10:11:59 EDStation.localdomain bumblebeed[582]: [ 1257.728412] [ERROR][XORG] (EE)                                                                                                            
août 04 10:11:59 EDStation.localdomain bumblebeed[582]: [ 1257.728417] [ERROR][XORG] (EE) Please also check the log file at "/var/log/Xorg.8.log" for additional information.                        
août 04 10:11:59 EDStation.localdomain bumblebeed[582]: [ 1257.728420] [ERROR][XORG] (EE)                                                                                                            
août 04 10:11:59 EDStation.localdomain bumblebeed[582]: [ 1257.728423] [ERROR][XORG] (EE) Server terminated with error (1). Closing log file.                                                        
août 04 10:11:59 EDStation.localdomain bumblebeed[582]: [ 1257.728426] [ERROR]X did not start properly

Comment 10 Gianluca Cecchi 2013-08-20 16:26:59 UTC
I confirm still here for my Asus U36SD laptop (see also comment#5).
Bad is that after trying and failing, the discrete graphic adapter also fails to be disabled so that battery life decreases of about 1h10m without any gain... and you are forced to reboot to have it disabled again.

Currently using:
kernel 3.10.7-200.fc19.x86_64
bumblebee-3.2.1-4.fc19.x86_64
xorg-x11-drv-nouveau-1.0.9-1.fc19.x86_64

Can influence using proprietary nvidia driver or is this problem directly a kernel and/or Xorg issue? 

example:
starting test with battery life marked as 4h 2m

no nouveau detected by sensors:
[g.cecchi@ope46 ~]$ sudo sensors
[sudo] password for g.cecchi: 
acpitz-virtual-0
Adapter: Virtual device
temp1:        +46.0°C  (crit = +108.0°C)

asus-isa-0000
Adapter: ISA adapter
temp1:        +46.0°C  

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +47.0°C  (high = +86.0°C, crit = +100.0°C)
Core 0:         +45.0°C  (high = +86.0°C, crit = +100.0°C)
Core 1:         +46.0°C  (high = +86.0°C, crit = +100.0°C)

In fact it is disabled:
[g.cecchi@ope46 ~]$ sudo lspci -v|grep -i vga
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller: NVIDIA Corporation GF119M [GeForce GT 520M] (rev ff) (prog-if ff)

try to run glxgears through optimus:
[g.cecchi@ope46 ~]$ sudo optirun glxgears
[  232.769948] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NOUVEAU(0): [drm] failed to set drm interface version.

[  232.770057] [ERROR]Aborting because fallback start is disabled.

Now:
[g.cecchi@ope46 ~]$ sudo lspci -v|grep -i vga
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])

and battery life marked as 2h 54m

it appears nouveau that has not been disabled also from sensors output:

[g.cecchi@ope46 ~]$ sudo sensors
acpitz-virtual-0
Adapter: Virtual device
temp1:        +50.0°C  (crit = +108.0°C)

nouveau-pci-0100
Adapter: PCI adapter
temp1:        +42.0°C  (high = +95.0°C, hyst =  +3.0°C)
                       (crit = +105.0°C, hyst =  +5.0°C)
                       (emerg = +135.0°C, hyst =  +5.0°C)

asus-isa-0000
Adapter: ISA adapter
temp1:        +50.0°C  

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +51.0°C  (high = +86.0°C, crit = +100.0°C)
Core 0:         +50.0°C  (high = +86.0°C, crit = +100.0°C)
Core 1:         +50.0°C  (high = +86.0°C, crit = +100.0°C)


Messages:
Aug 20 09:00:57 ope46 kernel: [  231.756503] bbswitch: enabling discrete graphics
Aug 20 09:00:57 ope46 kernel: [  232.133629] pci 0000:01:00.0: power state changed by ACPI to D0
Aug 20 09:00:57 ope46 kernel: [  232.180504] MXM: GUID detected in BIOS
Aug 20 09:00:57 ope46 kernel: [  232.180558] ACPI Error: Needed [Buffer/String/Package], found [Integer] ffff8802305af870 (20130328/exresop-590)
Aug 20 09:00:57 ope46 kernel: [  232.180565] ACPI Exception: AE_AML_OPERAND_TYPE, While resolving operands for [OpcodeName unavailable] (20130328/dswexec-460)
Aug 20 09:00:57 ope46 kernel: [  232.180571] ACPI Error: Method parse/execution failed [\_SB_.PCI0.GFX0._DSM] (Node ffff88024388d4b0), AE_AML_OPERAND_TYPE (20130328/psparse-537)
Aug 20 09:00:57 ope46 kernel: [  232.180585] failed to evaluate _DSM: 12291
Aug 20 09:00:57 ope46 kernel: [  232.180710] ACPI Error: Needed [Buffer/String/Package], found [Integer] ffff8802305af870 (20130328/exresop-590)
Aug 20 09:00:57 ope46 kernel: [  232.180714] ACPI Exception: AE_AML_OPERAND_TYPE, While resolving operands for [OpcodeName unavailable] (20130328/dswexec-460)
Aug 20 09:00:57 ope46 kernel: [  232.180719] ACPI Error: Method parse/execution failed [\_SB_.PCI0.GFX0._DSM] (Node ffff88024388d4b0), AE_AML_OPERAND_TYPE (20130328/psparse-537)
Aug 20 09:00:57 ope46 kernel: [  232.180726] ACPI Error: Method parse/execution failed [\_SB_.PCI0.PEG0.GFX0._DSM] (Node ffff8802438a29b0), AE_AML_OPERAND_TYPE (20130328/psparse-537)
Aug 20 09:00:57 ope46 kernel: [  232.180735] failed to evaluate _DSM: 12291
Aug 20 09:00:57 ope46 kernel: [  232.180827] VGA switcheroo: detected Optimus DSM method \_SB_.PCI0.PEG0.GFX0 handle
Aug 20 09:00:57 ope46 kernel: [  232.181398] nouveau  [  DEVICE][0000:01:00.0] BOOT0  : 0x0d9100a1
Aug 20 09:00:57 ope46 kernel: [  232.181404] nouveau  [  DEVICE][0000:01:00.0] Chipset: GF119 (NVD9)
Aug 20 09:00:57 ope46 kernel: [  232.181408] nouveau  [  DEVICE][0000:01:00.0] Family : NVD0
Aug 20 09:00:57 ope46 kernel: [  232.184998] nouveau  [   VBIOS][0000:01:00.0] checking PRAMIN for image...
Aug 20 09:00:57 ope46 kernel: [  232.233131] nouveau  [   VBIOS][0000:01:00.0] ... signature not found
Aug 20 09:00:57 ope46 kernel: [  232.233145] nouveau  [   VBIOS][0000:01:00.0] checking PROM for image...
Aug 20 09:00:57 ope46 kernel: [  232.233221] nouveau  [   VBIOS][0000:01:00.0] ... signature not found
Aug 20 09:00:57 ope46 kernel: [  232.233226] nouveau  [   VBIOS][0000:01:00.0] checking ACPI for image...
Aug 20 09:00:57 ope46 kernel: [  232.492187] nouveau  [   VBIOS][0000:01:00.0] ... appears to be valid
Aug 20 09:00:57 ope46 kernel: [  232.492196] nouveau  [   VBIOS][0000:01:00.0] using image from ACPI
Aug 20 09:00:57 ope46 kernel: [  232.492475] nouveau  [   VBIOS][0000:01:00.0] BIT signature found
Aug 20 09:00:57 ope46 kernel: [  232.492482] nouveau  [   VBIOS][0000:01:00.0] version 75.19.21.00.a4
Aug 20 09:00:57 ope46 kernel: [  232.493996] nouveau  [ DEVINIT][0000:01:00.0] adaptor not initialised
Aug 20 09:00:57 ope46 kernel: [  232.494002] nouveau  [   VBIOS][0000:01:00.0] running init tables
Aug 20 09:00:57 ope46 kernel: [  232.632925] nouveau  [     PFB][0000:01:00.0] RAM type: DDR3
Aug 20 09:00:57 ope46 kernel: [  232.632927] nouveau  [     PFB][0000:01:00.0] RAM size: 1024 MiB
Aug 20 09:00:57 ope46 kernel: [  232.632929] nouveau  [     PFB][0000:01:00.0]    ZCOMP: 0 tags
Aug 20 09:00:57 ope46 kernel: [  232.658261] nouveau  [  PTHERM][0000:01:00.0] FAN control: none / external
Aug 20 09:00:57 ope46 kernel: [  232.658265] nouveau  [  PTHERM][0000:01:00.0] fan management: disabled
Aug 20 09:00:57 ope46 kernel: [  232.658269] nouveau  [  PTHERM][0000:01:00.0] internal sensor: yes
Aug 20 09:00:57 ope46 kernel: [  232.661281] vga_switcheroo: enabled
Aug 20 09:00:57 ope46 kernel: [  232.661477] [TTM] Zone  kernel: Available graphics memory: 4039854 kiB
Aug 20 09:00:57 ope46 kernel: [  232.661483] [TTM] Zone   dma32: Available graphics memory: 2097152 kiB
Aug 20 09:00:57 ope46 kernel: [  232.661486] [TTM] Initializing pool allocator
Aug 20 09:00:57 ope46 kernel: [  232.661496] [TTM] Initializing DMA pool allocator
Aug 20 09:00:57 ope46 kernel: [  232.663840] nouveau  [     DRM] VRAM: 1024 MiB
Aug 20 09:00:57 ope46 kernel: [  232.663843] nouveau  [     DRM] GART: 512 MiB
Aug 20 09:00:57 ope46 kernel: [  232.663857] nouveau  [     DRM] TMDS table version 2.0
Aug 20 09:00:57 ope46 kernel: [  232.663859] nouveau  [     DRM] DCB version 4.0
Aug 20 09:00:57 ope46 kernel: [  232.663862] nouveau  [     DRM] DCB outp 00: 02000300 00000000
Aug 20 09:00:57 ope46 kernel: [  232.663864] nouveau  [     DRM] DCB conn 00: 00000000
Aug 20 09:00:57 ope46 kernel: [  232.664590] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
Aug 20 09:00:57 ope46 kernel: [  232.664592] [drm] No driver support for vblank timestamp query.
Aug 20 09:00:57 ope46 kernel: [  232.664601] nouveau  [     DRM] ACPI backlight interface available, not registering our own
Aug 20 09:00:57 ope46 kernel: [  232.664791] nouveau  [     DRM] 1 available performance level(s)
Aug 20 09:00:57 ope46 kernel: [  232.664795] nouveau  [     DRM] 1: core 270MHz shader 540MHz memory 405MHz
Aug 20 09:00:57 ope46 kernel: [  232.664798] nouveau  [     DRM] c: core 270MHz shader 540MHz memory 405MHz voltage 850mV
Aug 20 09:00:57 ope46 kernel: [  232.669230] nouveau  [     DRM] MM: using COPY0 for buffer copies
Aug 20 09:00:58 ope46 kernel: [  232.710898] nouveau  [     DRM] allocated 1024x768 fb: 0x60000, bo ffff880241258400
Aug 20 09:00:58 ope46 kernel: [  232.710983] nouveau 0000:01:00.0: fb1: nouveaufb frame buffer device
Aug 20 09:00:58 ope46 kernel: [  232.710985] [drm] Initialized nouveau 1.1.1 20120801 for 0000:01:00.0 on minor 1
Aug 20 09:00:58 ope46 bumblebeed[327]: [  232.766684] [ERROR][XORG] (EE) NOUVEAU(0): [drm] failed to set drm interface version.
Aug 20 09:00:58 ope46 bumblebeed[327]: [  232.766735] [ERROR][XORG] (EE) NOUVEAU(0): [drm] error opening the drm
Aug 20 09:00:58 ope46 bumblebeed[327]: [  232.766749] [ERROR][XORG] (EE) NOUVEAU(0): 835:
Aug 20 09:00:58 ope46 bumblebeed[327]: [  232.766763] [ERROR][XORG] (EE) Screen(s) found, but none have a usable configuration.
Aug 20 09:00:58 ope46 bumblebeed[327]: [  232.766774] [ERROR][XORG] (EE)
Aug 20 09:00:58 ope46 bumblebeed[327]: [  232.766790] [ERROR][XORG] (EE) no screens found(EE)
Aug 20 09:00:58 ope46 bumblebeed[327]: [  232.766802] [ERROR][XORG] (EE)
Aug 20 09:00:58 ope46 bumblebeed[327]: [  232.766817] [ERROR][XORG] (EE) Please also check the log file at "/var/log/Xorg.8.log" for additional information.
Aug 20 09:00:58 ope46 bumblebeed[327]: [  232.766829] [ERROR][XORG] (EE)
Aug 20 09:00:58 ope46 bumblebeed[327]: [  232.766841] [ERROR][XORG] (EE) Server terminated with error (1). Closing log file.
Aug 20 09:00:58 ope46 bumblebeed[327]: [  232.769852] [ERROR]X did not start properly
Aug 20 09:01:27 ope46 gnome-session[1429]: Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x1a00029 (Unsaved Do)
Aug 20 09:01:27 ope46 gnome-session[1429]: Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.

It would be fine to get any feedback or if we have to go upstream asking to fix for this...

Thanks,
Gianluca

Comment 11 Gianluca Cecchi 2013-08-20 16:31:09 UTC
In my previous comment the output of lspci after trying to run optirun with error wasn't correctly pasted; it should have been:

[g.cecchi@ope46 ~]$ sudo lspci -v |grep -i vga
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller: NVIDIA Corporation GF119M [GeForce GT 520M] (rev a1) (prog-if 00 [VGA controller])

with the

[VGA controller]

aside the nouveau line

sorry...

Comment 12 Ankur Sinha (FranciscoD) 2013-09-16 00:57:11 UTC
Just experienced this. Any one got a workaround?

     [  1330.063] (II) [drm] nouveau interface version: 1.1.1$
     [  1330.063] (II) Loading sub module "dri2"$
     [  1330.063] (II) LoadModule: "dri2"$
     [  1330.064] (II) Module "dri2" already built-in$
     [  1330.064] (EE) NOUVEAU(0): [drm] failed to set drm interface version.$
     [  1330.064] (EE) NOUVEAU(0): [drm] error opening the drm$
     [  1330.064] (EE) NOUVEAU(0): 835:-$
     [  1330.064] (II) UnloadModule: "nouveau"$
     [  1330.064] (EE) Screen(s) found, but none have a usable configuration.$
     [  1330.064] (EE)-$
     Fatal server error:$
     [  1330.064] (EE) no screens found(EE)-$

[asinha@ankur  bumblebee]$ rpm -q bumblebee xorg-x11-drv-nouveau
bumblebee-3.2.1-4.fc19.x86_64
xorg-x11-drv-nouveau-1.0.9-1.fc19.x86_64
[asinha@ankur  bumblebee]$

Comment 13 tod.jackson 2013-09-29 22:53:33 UTC
In my experience, bumblebee hasn't worked with nouveau since PRIME was in the kernel, around kernel 3.5 or 3.6. I don't think there's any way around that. Kernel 3.12 has added in-kernel power management, replacing bbswitch (it's pretty rough still, but works) and instead of optirun you'd run 'DRI_PRIME=1 program' after running xrandr --setprovideroffloadsink nouveau Intel and a compositor (xcompmgr would do).

Comment 14 Rob Crowther 2013-12-22 16:42:50 UTC
Bumblebee worked fine for me in F17 with kernel 3.10 and F18 with kernel 3.11, so there must be some way around it.  It doesn't work in F19.  I ran the xrandr command you suggested and got:

    Could not find provider with name nouveau

Comment 15 Isaac Lenton 2014-04-20 15:54:12 UTC
Still present in Fedora 20.

    $ rpm -q bumblebee xorg-x11-drv-nouveau
bumblebee-3.2.1-4.fc20.x86_64
xorg-x11-drv-nouveau-1.0.9-2.fc20.x86_64

Following Tod's suggestion (Comment 13) running the program with DRI_PRIME=1 seems to produce expected results.  Running xrandr with --setprovideroffloadsink didn't seem to have any effect and I wasn't sure what Tod meant by xcompmgr?

    $ xrandr --listproviders
Providers: number : 3
Provider 0: id: 0x8b cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 2 outputs: 4 associated providers: 2 name:Intel
Provider 1: id: 0x65 cap: 0x7, Source Output, Sink Output, Source Offload crtcs: 2 outputs: 4 associated providers: 2 name:nouveau
Provider 2: id: 0x65 cap: 0x7, Source Output, Sink Output, Source Offload crtcs: 2 outputs: 4 associated providers: 2 name:nouveau

So to recap, the following seems to work as expected:

$ DRI_PRIME=1 glxgears -info | grep "GL_VENDOR"

Comment 16 Isaac Lenton 2014-04-20 16:17:13 UTC
This (http://www.linuxfromscratch.org/blfs/view/svn/x/xorg-config.html) page discusses Hybrid Graphics (for Linux kernel's after 3.4, assume when PRIME was introduced):

    Xorg Server should load both GPU drivers automaticaly. In order to
    run a GLX application on a discrete GPU, you will need to export the
    DRI_PRIME=1 environment variable. For example,

    DRI_PRIME=1 glxinfo | egrep "(OpenGL vendor|OpenGL renderer|OpenGL version)"
    will show OpenGL vendor, renderer and version for the discrete GPU.

    If the last command reports same OpenGL renderer with and without
    DRI_PRIME=1, you will need to check your installation.

See also this (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=723733) debian bug reporting a similar issue (some useful discussion/links down the bottom/middle).

Possibly this bug could be closed (WONTFIX)?  My understanding is that this issue wont be fixed until the equivalent of bumblebee is implemented native to the kernel?

I will add a note on the Bumblebee installation page (https://fedoraproject.org/wiki/Bumblebee#Testing_Bumblebee) about DRI_PRIME.

Comment 17 Sam Tuke 2014-11-08 22:29:18 UTC
I also experience this problem on Fedora 20, with Bumblebee 3.2.1, 5.fc20.

Comment 18 Fedora End Of Life 2015-01-09 18:08:15 UTC
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 19 Gary Gatling 2015-01-18 22:57:41 UTC
Ok. The problem is that the package xorg-x11-drv-modesetting conflicts with using the nouveau driver with bumblebee. So it has to be removed for bumblebee to work.

Contemplating creating a bumblebee-nouveau package that would conflict with xorg-x11-drv-modesetting for users who want to use nouveau with bumblebee.

Comment 20 Gary Gatling 2015-02-17 01:01:22 UTC
In order to get bumblebee to work with the nouveau driver it was necessary to create a  bumblebee-nouveau package. That package adds a /etc/X11/xorg.conf.d/10-disable_prime.conf file that looks like this:


http://fpaste.org/186311/42413465/

In addition it adds a selinux security policy. The selinux security policy looks like this:

http://fpaste.org/186296/

This package is availible in my "bumblebee" yum/dnf repo for fedora 20/21 and RHEL 7. It does not work with RHEL 6 for some reason. Sorry it is not available for fedora 19 as it is end of life. 

Hope that helps.

Comment 21 Gary Gatling 2015-02-17 01:04:50 UTC
Also, forgot to mention bumblebee-nouveau conflicts with xorg-x11-drv-modesetting on purpose. It seems modesetting is incompatible with bumblebee + nouveau. So you'll need to remove that first if you want to use bumblebee + nouveau. A reboot is also required for the 10-disable_prime.conf to take effect on the primary X server (0 not 8). Cheers.

Comment 22 Fedora End Of Life 2015-02-17 15:15:29 UTC
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.