Bug 97204

Summary: eth0 crashes when trying to ACTIVATE with DHCP
Product: [Retired] Red Hat Linux Reporter: B. Smith <clear_0160>
Component: net-toolsAssignee: Phil Knirsch <pknirsch>
Status: CLOSED WORKSFORME QA Contact: Ben Levenson <benl>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-06-12 14:34:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description B. Smith 2003-06-11 15:37:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
I had a hub on my win\lin network.  Using SMB to connex.  I pulled the hub and 
replaced it with a D-LINK DSL router.  Now the system throws an error on the 
eth0 card when I try to use DHCP.  I had the network set to a static IP for the local network and I maybe missing something in switchover.  I 
have tried to set up an eth1, but it is throwing same error.  Also, running 
APACHE as localhost,  eth0 is only listed card in System Settings | 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.set up Eth0 as static IP on hub
2.switch to DSL router
3.update Eth0 to DHCP
4.Try Activating Eth0 card from xwindows | System Settings | Network
5.error thrown

Actual Results:  Here is error dump::
Traceback ( most recent call last):
 File "/usr/sbin/neat", line 689, in on_deviceActivatButton_clicked
 if self.save()!=0;
 File"/usr/sbin/neat", line 319 in save
 File"/usr/sbin/neat", Line 326, in saveDevices
  line 145, in save
 os.write(fp2, ipc.networ()+'/'+ipc.prefix()+"via "+rout.Gateway+"\n")
 File"/usr/sbin/../share/redhat-config-network/netconfphk/ipcalc.py", line 58,
 in network
line 37, in prefix self.netmask= re.match("NETMASK=(\s+)", text_g

Comment 1 B. Smith 2003-06-12 14:34:50 UTC
I seem to have resolved this problem.
Action Taken:: < In xWindows|System Settings|Network >
1. Uloaded all etho devices
2. Added my Router IP to HOSTS tab
3. Added Router IP to DNS tab
4. Re-installed the ETHO device

B. Smith