Bug 100544

Summary: national chars doesn't work in some applications
Product: [Retired] Red Hat Linux Beta Reporter: Thomas M Steenholdt <tmus>
Component: openoffice.orgAssignee: Dan Williams <dcbw>
Status: CLOSED DUPLICATE QA Contact: Dale Lovelace <dale>
Severity: medium Docs Contact:
Priority: medium    
Version: beta1CC: mitr
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-11-01 19:42:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Thomas M Steenholdt 2003-07-23 10:35:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

Description of problem:
In Severn (as well as RHL 8.0 and RHL 9) some national chars does not work in
some applications... 
In my case it's the Danish national chars that does not work in OpenOffice
(probably other apps as well) using the default setup.

My Language options are as follows:
LANG="en_DK.UTF-8"
SUPPORTED="en_DK.UTF-8:en_DK:en_US.UTF-8:en_US:en"

I did find however that setting LC_ALL="C" as well would solve my problems.
Now, there might be a reason why this setting is not there by default, but in
any other case, please include that setting in /etc/sysconfig/i18n by default :)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RHL8.0 RHL9 or Severn - Choose English(Denmark) as lang pref.
2. Launch oowriter after installation; try the danish national chars(won't work)
3. Launch LC_ALL="C" oowriter; try the danish national chars(will work)
    

Actual Results:  In the default configuration nothing is displayen in the
document when using the danish national chars. After running it with LC_ALL="C"
it works just fine!

Expected Results:  It should work out of the box!!!

Additional info:

Comment 1 Dan Williams 2004-02-27 16:30:01 UTC
Combining template bugs/requests

*** This bug has been marked as a duplicate of 84777 ***

Comment 2 Dan Williams 2004-02-27 16:31:09 UTC
Erg, wrong bug.  

Comment 3 Dan Williams 2004-02-27 16:31:38 UTC
combining en_DK bugs

*** This bug has been marked as a duplicate of 82895 ***

Comment 4 Caolan McNamara 2004-11-01 19:42:46 UTC
close as duplicate