This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 1006493 (CVE-2013-5651)

Summary: CVE-2013-5651 libvirt: virBitmapParse out-of-bounds read access
Product: [Other] Security Response Reporter: Petr Matousek <pmatouse>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: acathrow, berrange, bsarathy, clalancette, dallan, eblake, itamar, jdenemar, jforbes, jkurik, jyang, laine, libvirt-maint, pfrields, veillard, virt-maint
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: impact=moderate,public=20130829,reported=20130816,source=upstream,cvss2=3.3/AV:A/AC:L/Au:N/C:N/I:N/A:P,rhel-5/libvirt=notaffected,rhel-6.4.z/libvirt=notaffected,rhel-6.5/libvirt=affected,fedora-all/libvirt=affected,rhel-7/libvirt=affected,cwe=CWE-125[auto]
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-09-10 14:00:26 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 997367, 997906, 1006511    
Bug Blocks: 1006495    

Description Petr Matousek 2013-09-10 13:39:38 EDT
The virBitmapParse function was calling virBitmapIsSet() function that requires the caller to check the bounds of the bitmap without checking them. This resulted into crashes when parsing a bitmap string that was exceeding the bounds used as argument.

Introduced by:
http://libvirt.org/git/?p=libvirt.git;a=commit;h=0fc89098a68f0f6962de8be4fc03ddd960ffbf08

Upstream fix:
http://libvirt.org/git/?p=libvirt.git;a=commit;h=47b9127e883677a0d60d767030a147450e919a
Comment 1 Petr Matousek 2013-09-10 13:44:18 EDT
Statement:

Not vulnerable.

This issue did not affect the versions of libvirt package as shipped with Red Hat Enterprise Linux 5 and 6.
Comment 2 Petr Matousek 2013-09-10 14:15:03 EDT
Created libvirt tracking bugs for this issue:

Affects: fedora-all [bug 1006511]
Comment 3 Fedora Update System 2013-10-02 02:41:13 EDT
libvirt-1.0.5.6-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.