Bug 1015259 (CVE-2013-4401)

Summary: CVE-2013-4401 libvirt: unintended API access due to incorrect permissions checks
Product: [Other] Security Response Reporter: Vincent Danen <vdanen>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED NOTABUG QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: unspecifiedCC: acathrow, berrange, eblake, jdenemar, pfrields, pmatouse, security-response-team
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: impact=important,public=20131021,reported=20131002,source=redhat,cvss2=7.4/AV:A/AC:M/Au:S/C:C/I:C/A:C,rhel-7/libvirt=notaffected,rhel-6/libvirt=notaffected
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-10-03 14:23:48 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 1015260    
Bug Blocks:    

Description Vincent Danen 2013-10-03 14:21:18 EDT
A flaw was found in libvirt where libvirtd could crash due to how XML was parsed [1].  With the introduction of ACL permissions in libvirt 1.1.0, this flaw could be manipulated to allow a remote user with connect:read privileges to elevate them to the more permissive domain:write privilege.

This vulnerability was introduced in libvirt 1.1.0.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1012196;
Comment 2 Vincent Danen 2013-10-03 14:23:48 EDT
Statement:

Not vulnerable.

This issue did not affect the versions of libvirt package as shipped with Red Hat Enterprise Linux 5 and 6.