Bug 1015535

Summary: Maven repo zip does not contain jboss-as-client-all jar
Product: [JBoss] JBoss Enterprise Application Platform 6 Reporter: Nikoleta Ziakova <nziakova>
Component: Maven RepositoryAssignee: Paul Gier <pgier>
Status: CLOSED CURRENTRELEASE QA Contact: Nikoleta Ziakova <nziakova>
Severity: unspecified Docs Contact: Russell Dickenson <rdickens>
Priority: unspecified    
Version: 6.2.0CC: bsutter, dosoudil, myarboro, pgier, rsvoboda, ttarrant
Target Milestone: ER5Keywords: Regression
Target Release: EAP 6.2.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-12-15 11:19:11 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1010473    

Description Nikoleta Ziakova 2013-10-04 09:06:51 EDT
EAP 6.2.0 ER4 Maven repo zip does not contain jboss-as-client-all jar which is present in EAP zip (with different name: jboss-client.jar).
Comment 1 Rostislav Svoboda 2013-10-04 10:23:16 EDT
This artifact was present in maven repo zip in prior releases

ER4 was planned to be build with minimum changes and mainly blocker issues fixes, this is unexpected regression.

Example from EAP 6.2.0 ER3 
620ER3/jboss-eap-6.2.0.Beta1-maven-repository/org/jboss/as/jboss-as-client-all/7.3.0.Final-redhat-6/jboss-as-client-all-7.3.0.Final-redhat-6.pom
620ER3/jboss-eap-6.2.0.Beta1-maven-repository/org/jboss/as/jboss-as-client-all/7.3.0.Final-redhat-6/jboss-as-client-all-7.3.0.Final-redhat-6.pom.sha1
620ER3/jboss-eap-6.2.0.Beta1-maven-repository/org/jboss/as/jboss-as-client-all/7.3.0.Final-redhat-6/jboss-as-client-all-7.3.0.Final-redhat-6.pom.md5
620ER3/jboss-eap-6.2.0.Beta1-maven-repository/org/jboss/as/jboss-as-client-all/7.3.0.Final-redhat-6/jboss-as-client-all-7.3.0.Final-redhat-6.jar.sha1
620ER3/jboss-eap-6.2.0.Beta1-maven-repository/org/jboss/as/jboss-as-client-all/7.3.0.Final-redhat-6/jboss-as-client-all-7.3.0.Final-redhat-6.jar
620ER3/jboss-eap-6.2.0.Beta1-maven-repository/org/jboss/as/jboss-as-client-all/7.3.0.Final-redhat-6/jboss-as-client-all-7.3.0.Final-redhat-6.jar.md5
Comment 2 Paul Gier 2013-10-06 21:04:50 EDT
Removing this jar was intentional because shaded jars such as this one should not be used from a Maven repository.  The purpose of the client-all jar is for use in a non-Maven build.

We did some automation improvements to the Maven repo zip and apparently this was fixed due to the automation changes.  Was this jar included in EAP 6.1.1?
Comment 3 Nikoleta Ziakova 2013-10-07 03:06:53 EDT
Yes, this jar was included in 6.1.1 GA:

./jboss-eap-6.1.1.GA-maven-repository/org/jboss/as/jboss-as-client-all/7.2.1.Final-redhat-10/jboss-as-client-all-7.2.1.Final-redhat-10-sources.jar.sha1
./jboss-eap-6.1.1.GA-maven-repository/org/jboss/as/jboss-as-client-all/7.2.1.Final-redhat-10/jboss-as-client-all-7.2.1.Final-redhat-10.pom.sha1
./jboss-eap-6.1.1.GA-maven-repository/org/jboss/as/jboss-as-client-all/7.2.1.Final-redhat-10/jboss-as-client-all-7.2.1.Final-redhat-10-sources.jar.md5
./jboss-eap-6.1.1.GA-maven-repository/org/jboss/as/jboss-as-client-all/7.2.1.Final-redhat-10/jboss-as-client-all-7.2.1.Final-redhat-10-sources.jar
./jboss-eap-6.1.1.GA-maven-repository/org/jboss/as/jboss-as-client-all/7.2.1.Final-redhat-10/jboss-as-client-all-7.2.1.Final-redhat-10.jar.md5
./jboss-eap-6.1.1.GA-maven-repository/org/jboss/as/jboss-as-client-all/7.2.1.Final-redhat-10/jboss-as-client-all-7.2.1.Final-redhat-10.pom.md5
./jboss-eap-6.1.1.GA-maven-repository/org/jboss/as/jboss-as-client-all/7.2.1.Final-redhat-10/jboss-as-client-all-7.2.1.Final-redhat-10.pom
./jboss-eap-6.1.1.GA-maven-repository/org/jboss/as/jboss-as-client-all/7.2.1.Final-redhat-10/jboss-as-client-all-7.2.1.Final-redhat-10.jar
./jboss-eap-6.1.1.GA-maven-repository/org/jboss/as/jboss-as-client-all/7.2.1.Final-redhat-10/jboss-as-client-all-7.2.1.Final-redhat-10.jar.sha1
Comment 4 Nikoleta Ziakova 2013-10-07 08:56:24 EDT
Hi Paul,
it could be OK to remove the jar if there was a replacement for it. Is there any way for customers to get the correct dependencies without it?
Comment 5 Paul Gier 2013-10-07 10:27:29 EDT
For ER5 we will include the client-all jar again, and add a note to the documentation that this jar should not be used from the Maven repository.  Either the ejb-client-bom or jms-client-bom should be used instead.
Comment 9 Nikoleta Ziakova 2013-10-08 10:45:24 EDT
EAP 6.2.0 ER5 Maven repo zip contains jboss-as-client-all-7.3.0.Final-redhat-8.jar.

Please make the note to the documentation before the jar is removed again so we can test it accordingly.

I am setting this BZ verified and going to create a new one for the documentation.