Bug 1016157

Summary: mingw-virt-viewer-0.5.6-6.el6_4 only, on Windows 8, fails to run if you copy "virt-viewer" to the desktop.
Product: Red Hat Enterprise Virtualization Manager Reporter: Bill Sanford <bsanford>
Component: mingw-virt-viewerAssignee: Default Assignee for SPICE Bugs <rh-spice-bugs>
Status: CLOSED CURRENTRELEASE QA Contact: Desktop QE <desktop-qa-list>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 3.3.0CC: acathrow, bsanford, cfergeau, dblechte, gklein, iheim, jjongsma, michal.skrivanek, mkrcmari, pvine, Rhev-m-bugs, vipatel, yeylon, zdover
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: spice
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-07-08 07:35:14 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Spice RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Bill Sanford 2013-10-07 11:47:30 EDT
Description of problem:
When I install mingw-virt-viewer *only* from 
https://brewweb.devel.redhat.com/buildinfo?buildID=297777 on a Windows 8 client, I get an error of "The program can't start because libgdk-win32-2.0-0.dll is missing from your computer. Try reinstalling the program to fix this problem."

This is because I have the "virt-viewer" icon on the Desktop or "Pinned" to the taskbar. 

Using "remote-viewer" and copying that to the Desktop or "pinning" it to the taskbar, works.

Version-Release number of selected component (if applicable):
Windows 8.1 
mingw-virt-viewer-0.5.6-6.el6_4

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:
Virt-viewer installs and fails to load due to a missing dll.

Expected results:
Virt-viewer installs and works.

Additional info:
Comment 1 Tim Hildred 2013-10-27 20:03:31 EDT
Reassigning to Jodi Biddle (jbiddle@redhat.com) as I am no longer working on Red Hat Enterprise Virtualization documentation.
Comment 2 Zac Dover 2014-04-15 00:33:37 EDT
This is a component bug, not a docs bug.

I have reassigned it.
Comment 3 Michal Skrivanek 2014-04-16 03:13:22 EDT
(correcting component)
Comment 4 Christophe Fergeau 2014-04-16 03:35:12 EDT
We don't support running virt-viewer.exe, only remote-viewer.exe as this is what is used by RHEV.

What do you mean exactly by "I have the "virt-viewer" icon on the Desktop" or "copying that to the Desktop"? Where do you copy it from? Which detailed steps do you follow to do the copy (in other words, did you create a Windows shortcut, or did you perform an actual copy)?
Comment 5 Bill Sanford 2014-06-09 09:41:14 EDT
I am setting up some RHEV-M instances this week. I will retest this.
Comment 6 Bill Sanford 2014-07-07 13:48:00 EDT
I installed RHEV-M 3.4 (http://bob.eng.lab.tlv.redhat.com/builds/av10/el6/) in a RHEL 6.5 environment. I accessed the RHEV-M server from a Windows 8.1 client, first with the Console Invocation of "Browser Plugin" to download and install virt-viewer, then used the Console Invocation of "Native client" and launched the .vv file with remote-viewer.

This bug is verified fixed.