Bug 1016402

Summary: sssd-common in F20 has lower release number than in F19, leading to upgrade failing
Product: [Fedora] Fedora Reporter: Christian Horn <chorn>
Component: sssdAssignee: Jakub Hrozek <jhrozek>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 20CC: abokovoy, jhrozek, lslebodn, pbrezina, sbathe, sbose, sean_mccully, sgallagh, ssorce
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-10-31 12:31:36 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Christian Horn 2013-10-08 02:12:51 EDT
Description of problem:
  sssd-common in F20 has lower release than in F19

Version-Release number of selected component (if applicable):
  sssd-common-1.11.1-1.fc19.x86_64

How reproducible:
  always

Steps to Reproduce:
1. install Fedora19 as of today
2. yum --releasever=20 distro-sync

Actual results:
[...]
Error: Package: sssd-common-pac-1.11.1-1.fc19.x86_64 (@updates/19)
           Requires: sssd-common = 1.11.1-1.fc19
           Removing: sssd-common-1.11.1-1.fc19.x86_64 (@updates/19)
               sssd-common = 1.11.1-1.fc19
           Downgraded By: sssd-common-1.11.0-1.fc20.x86_64 (fedora)
               sssd-common = 1.11.0-1.fc20
[...]

Expected results:
No dependency issues

Additional info:
Comment 1 Christian Horn 2013-10-08 02:16:16 EDT
Looks like https://admin.fedoraproject.org/updates/sssd-1.11.1-2.fc20 is out of testing the issue is solved.
Comment 2 Jakub Hrozek 2013-10-08 04:01:51 EDT
I just submitted it to stable.
Comment 3 Jakub Hrozek 2013-10-08 04:03:28 EDT
*** Bug 1014900 has been marked as a duplicate of this bug. ***
Comment 4 Jakub Hrozek 2013-10-08 04:08:08 EDT
*** Bug 1016376 has been marked as a duplicate of this bug. ***
Comment 5 Christian Horn 2013-10-14 09:25:48 EDT
Hm.. issue still exists unchanged, so newer packages are apparently not yet in f20.
Comment 6 Sumit Bose 2013-10-14 09:57:16 EDT
ah, sorry, the latest version wasn't pushed to bodhi. I just did that. Feel free to give some karma at https://admin.fedoraproject.org/updates/sssd-1.11.1-3.fc20 .
Comment 7 Christian Horn 2013-10-16 10:44:00 EDT
Thanks, looks good now:

[root@hive ~]# yum --releasever=20 distro-sync
[...]
 sssd               x86_64      1.11.1-2.fc20     fedora            53 k
 sssd-ad            x86_64      1.11.1-2.fc20     fedora           139 k
 sssd-client        x86_64      1.11.1-2.fc20     fedora           107 k
[...]
Transaction Summary
===============================================================================
Install      12 Packages (+67 Dependent packages)
Upgrade    2066 Packages
Remove        2 Packages
Downgrade    12 Packages

Total download size: 1.5 G
Is this ok [y/d/N]:
Comment 8 Jakub Hrozek 2013-10-31 12:31:36 EDT
The issue was already fixed, closing.