Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.

Bug 101706

Summary: "Starting X" is still not translated
Product: [Retired] Red Hat Linux Beta Reporter: Noa Resare <noa>
Component: gnome-desktopAssignee: Mark McLoughlin <markmc>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: beta1CC: menthos
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-12-20 13:58:36 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 100644    

Description Noa Resare 2003-08-05 17:17:52 EDT
Description of problem:

the word "Starting" in for example "Starting Evolution" in the tasklist on the
panel is still not translated in Swedish locale.

I reported this in the previous beta cycle and hp marked it as fixed, but I
never saw the fix and rhl9 shipped with it untranslated. Bugzilla seems to have
been cleened from RESOLVED/FIXED entries.

I have tried to find where the string is set (have looked at gnome-panel,
startup-notification and metacity) but haven't found it. With a pointer in the
right direction I can find out why the string isn't translated myself.

The mix of languages when for example "Webbläsaren Mozilla" is localized but not
"Starting" is frustratingly unprofessional, especially when most of the other
translation is extermely good.
Comment 1 Havoc Pennington 2003-08-05 17:42:35 EDT
The string is in the "gnome-desktop" package.

Be sure it's translated upstream, get a new tarball of gnome-desktop 2.2.x 
released, then let me know and I'll download and build it.
Comment 2 Christian Rose 2003-08-06 08:17:57 EDT
This message has been translated upstream since 2002-11-27:
http://cvs.gnome.org/bonsai/cvsblame.cgi?file=gnome-desktop%2Fpo/sv.po&rev=gnome-2-2&root=/cvs/gnome
Comment 3 Havoc Pennington 2003-08-06 10:25:52 EDT
So I have gnome-desktop 2.2.2 in rawhide; if there's no translation with that, 
presumably the tarball was made before that date?
Or else there's some other problem with gnome-desktop...
Comment 4 Noa Resare 2003-08-06 11:46:11 EDT
The translation was there all the time. 

It seems like a textdomain() call is missing somewhere, because if I replace
_("Starting %s") with dcgettext(GETTEXT_PACKAGE, "Starting %s", LC_MESSAGES) the
translation works as intended.

Comment 5 Havoc Pennington 2003-08-06 14:34:40 EDT
I don't see the problem offhand. Should be sure this issue is opened on 
bugzilla.gnome.org as well.
Comment 6 Noa Resare 2003-08-06 14:57:51 EDT
I have file this on bugzilla.gnome.org as <a
href="http://bugzilla.gnome.org/createattachment.cgi?id=119280">#119280</a>
Comment 7 Noa Resare 2003-08-06 14:59:01 EDT
Ooops, wrong link. Try this instead:
http://bugzilla.gnome.org/show_bug.cgi?id=119280
Comment 8 Noa Resare 2003-12-20 13:58:36 EST
This works as expected in fc1