Bug 1024549

Summary: Bundled MD5
Product: [Fedora] Fedora Reporter: Michael Schwendt <bugs.michael>
Component: busyboxAssignee: Denys Vlasenko <dvlasenk>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 20CC: admiller, bruno_cornec, dvlasenk
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-04-14 11:23:32 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 476234    

Description Michael Schwendt 2013-10-29 18:27:04 EDT
Busybox contains two bundled implementations of MD5 and needs to follow the related packaging guidelines:


1) libbb/hash_md5_sha.c is an implementation by Ulrich Drepper, which is not known yet at https://fedoraproject.org/wiki/Packaging:No_Bundled_Libraries#cite_note-0
For a different implementation by Ulrich, see https://fedorahosted.org/fpc/ticket/130 where an exception and a name for it has been requested.

2) libbb/hash_md5prime.c is "not used by busybox right now" according to that file. It's based on an implementation by RSA, but has been edited [to an extend I haven't analyzed]. No action is needed for this implementation yet.
However, if you delete that source file during %prep, it won't be built with accidentally. ;)
Comment 1 Michael Schwendt 2014-02-19 08:08:02 EST
Here's the FPC's resolution since I haven't seen anyone else filing a ticket in their tracker:
Comment 2 Denys Vlasenko 2014-12-16 10:09:27 EST
I propose to close it as WONTFIX.

Busybox is meant to be used (among other scenarios) in emergency repairs. To this end, it's useful to have it statically linked, so that we don't depend on on NSS libs (or any other libs) to be present on the system.
Comment 3 Michael Schwendt 2014-12-16 11:37:31 EST
Why would you propose that?

Just follow 


and add "Provides: bundled(md5-drepper2)" to the package. See footnode 2.
Comment 4 Michael Schwendt 2015-04-14 11:23:32 EDT
Fix committed to Rawhide. No build request submitted, however.