Bug 1024710

Summary: engine vm should be powered off if user decides to reboot it and start again while hosted engine installation.
Product: Red Hat Enterprise Virtualization Manager Reporter: Leonid Natapov <lnatapov>
Component: ovirt-hosted-engine-setupAssignee: Yedidyah Bar David <didi>
Status: CLOSED ERRATA QA Contact: movciari
Severity: high Docs Contact:
Priority: medium    
Version: unspecifiedCC: aburden, dfediuck, iheim, oschreib, pablo.iranzo, pstehlik, sbonazzo, scohen, talayan
Target Milestone: ---Keywords: ZStream
Target Release: 3.4.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: integration
Fixed In Version: ovirt-3.4.0-beta2 Doc Type: Bug Fix
Doc Text:
* Previously, the 'hosted-engine --vm-start' command would fail if the hosted engine virtual machine already existed and had a status of 'down'. Now, setup automatically shuts down the virtual machine so that the 'hosted-engine --vm-start' command succeeds.
Story Points: ---
Clone Of:
: 1055495 (view as bug list) Environment:
Last Closed: 2014-06-09 14:47:23 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1055495, 1078909, 1142926    

Description Leonid Natapov 2013-10-30 09:48:09 UTC
After creation of VM during hosted engine setup there is a message saying that if user ,for some reason,decides to reboot the VM ,it should be started manually using hosted-engine --vm-start command.

The message is:
"If you need to reboot the VM you will need to start it manualy using the command hosted-engine --vm-start".

The problem is that when user reboots the vm it still exist. VdsClient shows the VM and its status is DOWN. So when user tries to run hosted-engine --vm-start command there is a message saying that Virtual Machine already exist. In order to run --vm-start user must run --vm-poweroff first.

So,setup must poweroff the VM automatically in order to let the user posibility to run hosted-engine --vm-start or give a message that user need to poweroff VM and than run --vm-start.

Comment 2 Sandro Bonazzola 2014-01-14 10:24:06 UTC
patch merged on upstream master branch for 3.4.0 rebase.

Comment 3 Yedidyah Bar David 2014-01-14 10:31:19 UTC
(In reply to Sandro Bonazzola from comment #2)
> patch merged on upstream master branch for 3.4.0 rebase.

Do we want this also in zstream? I think it's a simple-enough change and can go in. Not sure it's really needed.

Comment 5 Yedidyah Bar David 2014-01-29 10:30:39 UTC
Sebastian Classen reported on users@ what seems like a bug in 23219, pushed a fix 23823 and asked him to try to verify. I'll try that myself later, although it seems not easy to reproduce.

Comment 7 errata-xmlrpc 2014-06-09 14:47:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0505.html