Bug 102610

Summary: LG GCC-4480B DVD/CDRW combo not recognized as CD writer
Product: [Fedora] Fedora Reporter: Alexandre Oliva <oliva>
Component: cdrtoolsAssignee: Harald Hoyer <harald>
Status: CLOSED WORKSFORME QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-07-12 10:42:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Alexandre Oliva 2003-08-18 16:58:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
gtoaster doesn't detect that my LG DVD/CDRW combo is a CD writer.  I have to
explicitly check the box in Preferences -> CDROM and Recorder Setup -> Edit ->
This Drive is a CD writer.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start gtoaster for the first time after an install from scratch

Actual Results:  the combo is not taken as a CD writer

Expected Results:  it should

Additional info:

Here are the details gtoaster presents in the edit window:

Model: RW/DVD GCC-4480B
Manufacturer: HL-DT-ST
Device File: /dev/scd0
Scsi ID: 0,0,0
Mountpoint: egexp

This is SCSI emulation.  Mountpoint looks bogus too.

Comment 1 Alexandre Oliva 2003-10-13 15:11:23 UTC
The problem is actually in cdrecord, that prints:

# cdrecord -scanbus
Cdrecord-Clone 2.01a19 (i686-redhat-linux-gnu) Copyright (C) 1995-2003 J�rg
Schilling
Linux sg driver version: 3.1.25
Using libscg version 'schily-0.7'
cdrecord: Warning: using inofficial libscg transport code version (schily - Red
Hat-scsi-linux-sg.c-1.75-RH '@(#)scsi-linux-sg.c        1.75 02/10/21 Copyright
1997 J. Schilling').
scsibus0:
        0,0,0     0) 'HL-DT-ST' 'RW/DVD GCC-4480B' '1.00' Removable CD-ROM


Comment 2 Alexandre Oliva 2003-10-18 20:47:36 UTC
Err...  Why isn't cdrecord an option for Component, and why is cdrtools, that's
not in rawhide?

Comment 3 Alexandre Oliva 2003-10-19 02:26:34 UTC
As notting pointed out, it's the source rpm name that matters.

Comment 4 Harald Hoyer 2004-01-29 10:44:05 UTC
what can I do about it? Have any patch or hardware handy?
care to report to Jörg Schilling? :)

Comment 5 Alexandre Oliva 2004-05-07 03:49:03 UTC
FWIW, I tried contacting him, even using my non-Red Hat e-mail
address, to no avail :-(  Is there a mailing list or upstream bugzilla
or equivalent where I could report the problem?

Comment 6 Harald Hoyer 2004-05-07 07:19:15 UTC
no there isn't any bugzilla... did you try his cdrecord-pro with the
free license key?

Comment 7 Alexandre Oliva 2004-05-10 15:19:46 UTC
Just tried it.  It even fails to scan /dev/hdk (2.01a27), unless I
explicitly mention -dev=ATAPI:/dev/hdk (as opposed to just
-dev=ATAPI:, that works with the cdrecord we ship).  When I do specify
/dev/hdk, it reports it as `Removable CD-ROM', just like what we ship.

Comment 8 Harald Hoyer 2004-05-11 08:36:48 UTC
if you have time, you may generate a patch, as I do not have the HW...
thx in advance!

Comment 9 Harald Hoyer 2004-10-13 12:29:24 UTC
any progress with the new rawhide versions?

Comment 10 Harald Hoyer 2005-07-08 15:56:02 UTC
ping?

Comment 11 Alexandre Oliva 2005-07-11 18:25:26 UTC
It's still reported as follows:

        1,0,0   100) 'HL-DT-ST' 'RW/DVD GCC-4480B' '1.00' Removable CD-ROM

but this doesn't seem to confuse say xcdroast.  In fact, another CDRW/DVD combo
on the box that I now use as my desktop is reported as Removable CD-ROM as well,
but it works just fine too.  That's probably good enough.  Feel free to close.