This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 102629

Summary: multiload applet graph gets cleared on autohide panels
Product: [Fedora] Fedora Reporter: Nils Philippsen <nphilipp>
Component: gnome-appletsAssignee: Mark McLoughlin <markmc>
Status: CLOSED DUPLICATE QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: 1CC: bart.martens
Target Milestone: ---Keywords: MoveUpstream, Triaged
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 13:58:08 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
gnome-applets-2.4.1-realloc.patch none

Description Nils Philippsen 2003-08-19 01:40:18 EDT
Description of problem:

When putting the multiload applet on an autohide panel, the graph gets cleared
when the panel hides or shows again.

Version-Release number of selected component (if applicable):

gnome-applets-2.3.6-1

How reproducible:

Always

Steps to Reproduce:
1. Put multiload applet on autohide panel
2. Let panel hide/show
    
Actual results:

Graph(s) is/are black

Expected results:

Graph shows history of the last minute(s)
Comment 1 Nils Philippsen 2003-11-12 08:40:25 EST
Changed product to Fedora Core.

Looking at it again, the graph gets displayed properly for the
fraction of a second and only gets cleared after that.
Comment 2 Bart Martens 2004-02-13 12:37:17 EST
Created attachment 97652 [details]
gnome-applets-2.4.1-realloc.patch

When the multiload applet configure callback is called, don't clear the data if
the width hasn't changed.
Comment 3 Bart Martens 2004-02-13 12:49:36 EST
Note that when unhiding, the applet flashes. That is due to another
bug, probably in gnome-panel. Use the workaround mentioned of bug
#102632 to avoid the flashing.
Comment 4 Craig Routledge 2004-02-13 14:53:58 EST
I'm not seeing the clear on unhide problem with gnome-applet-2.4.1-1
in an updated FC1.

Is anyone still having the problem or should this be closed?

Comment 5 Nils Philippsen 2004-02-13 17:19:10 EST
I still see the problem on gnome-panel-2.4.0-3, gnome-applets-2.4.1-1.
The workaround in #102632 doesn't help me (neither with the panel
flickering nor with the multiload applet's redraw issue).
Comment 6 Craig Routledge 2004-02-13 23:57:19 EST
This bug has been submitted upstream by Bart Martens to:

http://bugzilla.gnome.org/show_bug.cgi?id=134337

After re-reading bug #102632, I noticed that it's instructions called
additionally for clearing the expand property of the panel.  When I
did so with this bug, it manifested.  It could, in my case, be
prevented by changing the panel background to another colour or an
image (the workaround mentioned above).

triage->upstream
Comment 7 Bart Martens 2004-02-14 11:34:46 EST
Comment on attachment 97652 [details]
gnome-applets-2.4.1-realloc.patch

Marking the patch as obsolete.
Comment 8 Bart Martens 2004-02-14 12:16:36 EST
I marked the patch of comment #2 as obsolete, for two reasons. First,
the patch solves the problem only for a horizontal panel, not for a
vertical one (thank you Dennis Smit). Second, I see now that the
workaround of comment #3 is not only suppresses the flashing, but
makes the whole bug disappear, for both a horizontal panel and a
vertical one.
Comment 9 Nils Philippsen 2004-02-14 15:00:38 EST
This is definitely not true here. See my latest comment (3) on bug
#102632.
Comment 10 Bart Martens 2004-02-15 08:04:24 EST
gnome-applets-2.4.1-1
gnome-panel-2.4.0-3

gnome-applets-2.4.1/multiload/load-graph.c
gnome-panel-2.4.0/gnome-panel/panel-toplevel.c

I found some more information with gdb. When auto-unhiding, function
load_graph_configure is called or not depending on whether the
gnome-panel background is none or color. How does that come? Well,
there is some logic in function panel_toplevel_update_edges that
causes resizing depending on whether the gnome-panel background is
none (PANEL_BACK_NONE) or something else. Disabling the lines from
1370 until 1394 makes the problem disappear, exactly like setting the
gnome-panel background to color. But disabling these lines has side
effects: no "bevels", so that's not the solution. The solution is
probably to do the "bevels"-stuff earlier, so not at auto-unhiding
time, to avoid the unneccessary resizing. So this may be a gnome-panel
bug instead of a gnome-applets bug. Maybe the solution will also fix
the problem of bug #102632.

I need some help on this. Anyone?

(Nils, are you sure you tested what Joseph Mocker wrote, that is,
setting the gnome-panel background to color? Three persons say that it
does make the problem disappear. I can't explain why this didn't have
the positive effect during your test. Could you check this again please?)
Comment 11 Bart Martens 2004-02-24 06:37:12 EST
Upstream info updated.
http://bugzilla.gnome.org/show_bug.cgi?id=134337

Comment 12 Bart Martens 2004-03-03 16:24:14 EST

*** This bug has been marked as a duplicate of 102632 ***
Comment 13 Red Hat Bugzilla 2006-02-21 13:58:08 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.