Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.

Bug 1027118

Summary: Rete tree build error with timer
Product: [Retired] JBoss BRMS Platform 6 Reporter: Tomas Schlosser <tschloss>
Component: Eclipse ToolingAssignee: Kris Verlaenen <kverlaen>
Status: CLOSED CURRENTRELEASE QA Contact: Tomas Schlosser <tschloss>
Severity: medium Docs Contact:
Priority: medium    
Version: unspecified   
Target Milestone: ER5   
Target Release: 6.0.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-08-06 16:19:56 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Tomas Schlosser 2013-11-06 03:13:40 EST
Description of problem:
The rete tree can't be built for rules containing timer.

Version-Release number of selected component (if applicable):
BRMS 6.0.0.ER4
JBDS 7.0.1.GA
Drools plugin 6.0.0.201308222359 (and also master as of 2013-11-06)

Steps to Reproduce:
1. create a rule resource containing one of the problem features
2. switch rule editor to "Rete Tree"

Actual results:
Rete Tree Build Error!

Expected results:
Rete tree.

Error log from Eclipse:
java.lang.reflect.InvocationTargetException
	at org.drools.eclipse.editors.DRLRuleEditor2$3.run(DRLRuleEditor2.java:248)
	at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)
Caused by: org.drools.core.RuntimeDroolsException: java.lang.reflect.InvocationTargetException : [Rete(0)]
	at org.drools.core.util.ReflectiveVisitor.visit(ReflectiveVisitor.java:59)
	at org.drools.eclipse.reteoo.ReteooVisitor.visitReteooRuleBase(ReteooVisitor.java:79)
	at org.drools.eclipse.editors.rete.ReteViewer.loadReteModel(ReteViewer.java:172)
	at org.drools.eclipse.editors.DRLRuleEditor2$3.run(DRLRuleEditor2.java:240)
	... 1 more
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.drools.core.util.ReflectiveVisitor.visit(ReflectiveVisitor.java:50)
	... 4 more
Caused by: org.drools.core.RuntimeDroolsException: java.lang.reflect.InvocationTargetException : [EntryPointNode(1) EntryPoint::DEFAULT ]
	at org.drools.core.util.ReflectiveVisitor.visit(ReflectiveVisitor.java:59)
	at org.drools.eclipse.reteoo.ReteooVisitor.visitRete(ReteooVisitor.java:97)
	... 9 more
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.drools.core.util.ReflectiveVisitor.visit(ReflectiveVisitor.java:50)
	... 10 more
Caused by: org.drools.core.RuntimeDroolsException: java.lang.reflect.InvocationTargetException : [ObjectTypeNode(5)::EntryPoint::DEFAULT objectType=[ClassObjectType class=org.drools.core.reteoo.InitialFactImpl] expiration=-1ms ]
	at org.drools.core.util.ReflectiveVisitor.visit(ReflectiveVisitor.java:59)
	at org.drools.eclipse.reteoo.ReteooVisitor.visitNode(ReteooVisitor.java:154)
	at org.drools.eclipse.reteoo.ReteooVisitor.visitBaseNode(ReteooVisitor.java:135)
	... 15 more
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.drools.core.util.ReflectiveVisitor.visit(ReflectiveVisitor.java:50)
	... 17 more
Caused by: org.drools.core.RuntimeDroolsException: java.lang.reflect.InvocationTargetException : [LeftInputAdapterNode(6)]
	at org.drools.core.util.ReflectiveVisitor.visit(ReflectiveVisitor.java:59)
	at org.drools.eclipse.reteoo.ReteooVisitor.visitNode(ReteooVisitor.java:154)
	at org.drools.eclipse.reteoo.ReteooVisitor.visitBaseNode(ReteooVisitor.java:135)
	... 22 more
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.drools.core.util.ReflectiveVisitor.visit(ReflectiveVisitor.java:50)
	... 24 more
Caused by: org.drools.core.RuntimeDroolsException: java.lang.reflect.InvocationTargetException : [TimeNodeNode: cond=org.drools.core.time.impl.IntervalTimer@38c0a868 calendars=null]
	at org.drools.core.util.ReflectiveVisitor.visit(ReflectiveVisitor.java:59)
	at org.drools.eclipse.reteoo.ReteooVisitor.visitNode(ReteooVisitor.java:154)
	at org.drools.eclipse.reteoo.ReteooVisitor.visitBaseNode(ReteooVisitor.java:135)
	... 29 more
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.drools.core.util.ReflectiveVisitor.visit(ReflectiveVisitor.java:50)
	... 31 more
Caused by: java.lang.RuntimeException: problem visiting vertex org.drools.core.reteoo.TimerNode
	at org.drools.eclipse.reteoo.ReteooVisitor.visitBaseNode(ReteooVisitor.java:110)
	... 36 more
Caused by: java.lang.ClassNotFoundException: org.drools.eclipse.reteoo.TimerNodeVertex cannot be found by org.drools.eclipse_6.0.0.201308222359
	at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:501)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:421)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:412)
	at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
	at java.lang.Class.forName0(Native Method)
	at java.lang.Class.forName(Class.java:190)
	at org.drools.eclipse.reteoo.ReteooVisitor.visitBaseNode(ReteooVisitor.java:107)
	... 36 more
Comment 2 Tomas Schlosser 2014-01-15 06:31:06 EST
Verified with Drools plugin 6.0.1.Final
Comment 3 JBoss JIRA Server 2014-02-12 03:57:17 EST
Mario Fusco <mario.fusco@gmail.com> updated the status of jira DROOLS-320 to Resolved