Bug 1033788

Summary: Safenet SC650 smart cards are not detected
Product: Red Hat Enterprise Linux 7 Reporter: Asha Akkiangady <aakkiang>
Component: pcsc-lite-ccidAssignee: Bob Relyea <rrelyea>
Status: CLOSED CURRENTRELEASE QA Contact: Asha Akkiangady <aakkiang>
Severity: unspecified Docs Contact:
Priority: medium    
Version: 7.0CC: arubin, jgalipea, jmagne, ludovic.rousseau, rpattath
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: pcsc-lite-ccid-1.4.10-3.el7 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-06-13 13:03:28 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Asha Akkiangady 2013-11-22 22:32:58 UTC
Description of problem:
Safenet SC650 smart cards are not detected.

Version-Release number of selected component (if applicable):
pcsc-lite-1.8.8-2.el7.x86_64

How reproducible:


Steps to Reproduce:
1. Open ESC application on RHEL 7
2. Plug Safenet SC 650 card on a Omnikey3121 reader


Actual results:
Smart card not detected.

/var/log/messages has this:
Nov 22 16:49:24 dhcp129-98 pcscd: 81444707 commands.c:237:CmdPowerOn Card absent or mute
Nov 22 16:49:24 dhcp129-98 pcscd: 00000015 ifdhandler.c:1188:IFDHPowerICC() PowerUp failed
Nov 22 16:49:24 dhcp129-98 pcscd: 00000015 eventhandler.c:403:EHStatusHandlerThread() Error powering up card.
Nov 22 16:49:26 dhcp129-98 pcscd: 01199014 commands.c:237:CmdPowerOn Card absent or mute
Nov 22 16:49:26 dhcp129-98 pcscd: 00000009 ifdhandler.c:1188:IFDHPowerICC() PowerUp failed
Nov 22 16:49:26 dhcp129-98 pcscd: 00000005 winscard.c:317:SCardConnect() Error powering up card: 2148532246 0x80100016
Nov 22 16:49:26 dhcp129-98 pcscd: 00000003 winscard.c:322:SCardConnect() Card Not Powered
Nov 22 16:49:26 dhcp129-98 pcscd: 00799003 commands.c:237:CmdPowerOn Card absent or mute
Nov 22 16:49:26 dhcp129-98 pcscd: 00000016 ifdhandler.c:1188:IFDHPowerICC() PowerUp failed
Nov 22 16:49:26 dhcp129-98 pcscd: 00000006 winscard.c:317:SCardConnect() Error powering up card: 2148532246 0x80100016
Nov 22 16:49:26 dhcp129-98 pcscd: 00000005 winscard.c:322:SCardConnect() Card Not Powered
Nov 22 16:49:27 dhcp129-98 pcscd: 00798981 commands.c:237:CmdPowerOn Card absent or mute
Nov 22 16:49:27 dhcp129-98 pcscd: 00000015 ifdhandler.c:1188:IFDHPowerICC() PowerUp failed
Nov 22 16:49:27 dhcp129-98 pcscd: 00000005 winscard.c:317:SCardConnect() Error powering up card: 2148532246 0x80100016
Nov 22 16:49:27 dhcp129-98 pcscd: 00000004 winscard.c:322:SCardConnect() Card Not Powered

Expected results:

Safenet SC 650 card should be detected.

Additional info:

Comment 2 Jack Magne 2013-11-22 22:38:14 UTC
Issue seems to be the missing magic param in the Info.plist for pcsc-lite-ccid:


vi /usr/lib64/pcsc/drivers/ifd-ccid.bundle/Contents/Info.plist


Make the following change:

 <key>ifdDriverOptions</key>
        <string>0x0020</string>


Out of the box the value is 0x0000

After doing this, the sc650 started getting recognized.

Comment 3 Bob Relyea 2013-11-26 18:52:58 UTC
<key>ifdDriverOptions</key>
        <string>0x0020</string>


This seems to indicate that the variable voltage code isn't in  upstream. I have a patch in RHEL 6 and RHEL 7 that alliviates the need for this change.

Comment 4 Bob Relyea 2013-11-26 23:23:12 UTC
Asha, can I get the qa ack back. I had to change the component to pcsc-lite-ccid. The package names changed between RHEL 6 and RHEL 7 (I know, confusing, but this is how upstream wanted them, so fedora changes them).

bob

Comment 5 Bob Relyea 2013-12-02 21:20:02 UTC
How do I get pm ack now? Once I have that I can create the errata for the patch.

Comment 7 Roshni 2014-02-07 17:35:49 UTC
Verified on pcsc-lite-ccid-1.4.10-5.el7.x86_64

Comment 8 Ludek Smid 2014-06-13 13:03:28 UTC
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Comment 10 Ludovic Rousseau 2017-01-07 18:22:16 UTC
The fix is now included in CCID 1.4.26
https://ludovicrousseau.blogspot.fr/2017/01/new-version-of-libccid-1426.html