Bug 1034060

Summary: append /usr/bin/zsh to /etc/shells
Product: [Fedora] Fedora Reporter: kealthou
Component: zshAssignee: Dominic Hopf <dmaphy>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 19CC: dmaphy, i, james.antill, mark
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: zsh-5.0.5-1.fc19 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-07-13 02:53:10 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description kealthou 2013-11-25 08:03:07 UTC
/bin/zsh is just a legacy path. Append /usr/bin/zsh to /etc/shells too, like bash.


Version-Release number of selected component (if applicable):
zsh-5.0.2-5.fc19.x86_64

Comment 1 Fedora Update System 2014-07-03 00:00:43 UTC
zsh-5.0.5-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/zsh-5.0.5-1.fc20

Comment 2 Fedora Update System 2014-07-03 00:01:00 UTC
zsh-5.0.5-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/zsh-5.0.5-1.fc19

Comment 3 Dominic Hopf 2014-07-03 00:11:37 UTC
Thanks very much for reporting this issue and your patience while I investigated some issues with building 5.0.5. The issue here rather was, that %{_bindir} was set to /bin in the package and thus the whole Zsh binary was installed to /bin before.

This behavior has now been changed and we're using the default value for %{_bindir} which points to /usr/bin. Since /bin is just a symbolic link to /usr/bin this should work without any issues and the correct path will be appended to /etc/shells now.

Please feel free to test this and provide me with feedback as soon as the update is available via updates-testing.

Comment 4 Christopher Meng 2014-07-03 04:09:56 UTC
(In reply to Dominic Hopf from comment #3)
> Thanks very much for reporting this issue and your patience while I
> investigated some issues with building 5.0.5. The issue here rather was,
> that %{_bindir} was set to /bin in the package and thus the whole Zsh binary
> was installed to /bin before.
> 
> This behavior has now been changed and we're using the default value for
> %{_bindir} which points to /usr/bin. Since /bin is just a symbolic link to
> /usr/bin this should work without any issues and the correct path will be
> appended to /etc/shells now.
> 
> Please feel free to test this and provide me with feedback as soon as the
> update is available via updates-testing.

Please take a look at this(my draft, turned into guideline as well):

https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Shells

Comment 5 Dominic Hopf 2014-07-03 09:13:54 UTC
That's probably right since the zsh could be invoked via /bin/zsh as well as /usr/bin/zsh. The link you posted does not cover the uninstallation process, though. Zsh does the following in %postun currently:

%postun
if [ "$1" = 0 ] ; then
    if [ -f %{_sysconfdir}/shells ] ; then
        TmpFile=`%{_bindir}/mktemp /tmp/.zshrpmXXXXXX`
        grep -v '^%{_bindir}/zsh$' %{_sysconfdir}/shells > $TmpFile
        cp -f $TmpFile %{_sysconfdir}/shells
        rm -f $TmpFile
    fi
fi

Are we able to just add something like that as well to the wiki page?

Comment 6 Christopher Meng 2014-07-03 09:32:51 UTC
(In reply to Dominic Hopf from comment #5)
> That's probably right since the zsh could be invoked via /bin/zsh as well as
> /usr/bin/zsh. The link you posted does not cover the uninstallation process,
> though. Zsh does the following in %postun currently:

Why didn't it cover the postun???

Comment 7 Dominic Hopf 2014-07-03 10:14:49 UTC
Seems I just overlooked something, sorry. I've applied this for Rawhide now.

Comment 8 Fedora Update System 2014-07-04 00:28:38 UTC
Package zsh-5.0.5-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing zsh-5.0.5-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8041/zsh-5.0.5-1.fc19
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2014-07-13 02:53:10 UTC
zsh-5.0.5-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2014-07-13 02:53:54 UTC
zsh-5.0.5-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.