Bug 1036586

Summary: rhn-channel with no parameters asks for user name and password only to return its usage message
Product: Red Hat Enterprise Linux 6 Reporter: Radek Bíba <rbiba>
Component: rhn-client-toolsAssignee: Matej Kollar <mkollar>
Status: CLOSED ERRATA QA Contact: Pavel Studeník <pstudeni>
Severity: low Docs Contact:
Priority: low    
Version: 6.5CC: cperry, dyordano, pstudeni
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: rhn-client-tools-1.0.0.1-24-el6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-07-22 07:28:48 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Radek Bíba 2013-12-02 10:21:27 UTC
Description of problem:
# rhn-channel
Username: <filtered out>
Password: 
ERROR: you may want to specify --add, --remove or --list

This is kind of strange. Why do I have to enter my credentials if the output then contains nothing about the system's subscription? The error should be printed right away.

Version-Release number of selected component (if applicable):
rhn-client-tools-1.0.0.1-16.el6

Comment 1 Matej Kollar 2015-02-20 20:44:32 UTC
Upstream work -- Spacewalk.git: ea4c950c3e7a40ece7af1daf4df85b9373f70825

Comment 4 Pavel Studeník 2015-03-17 15:44:02 UTC
Verified with rhn-setup-gnome-1.0.0.1-31.el6.noarch.rpm

# rhn-channel
ERROR: you may want to specify --add, --remove or --list

# echo $?
0

Comment 5 errata-xmlrpc 2015-07-22 07:28:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1395.html