Bug 1038314

Summary: Cyclic dependencies: erlang and erlang-examples
Product: [Fedora] Fedora Reporter: Jakub Jedelsky <jakub.jedelsky>
Component: erlangAssignee: Peter Lemenkov <lemenkov>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 19CC: erlang, lemenkov, rhbugs
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: erlang-17.2.1-1.fc21 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-08-27 18:54:09 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jakub Jedelsky 2013-12-04 21:22:04 UTC
Description of problem:
It is impossible to remove erlang package with /usr/bin/rpm command with erlang-examples and vice versa. There are cyclic dependencies among these two packages.

Version-Release number of selected component (if applicable):
erlang-R16B-02.3.fc19.x86_64

How reproducible:
always

Steps to Reproduce:
1. try to remove erlang
$ /usr/bin/rpm -e erlang
returns:
error: Failed dependencies:
erlang(x86-64) = R16B-02.3.fc19 is needed by (installed) erlang-examples-R16B-02.3.fc19.x86_64

2. try to remove erlang-examples
$ /usr/bin/rpm -e erlang-examples
returns:
error: Failed dependencies:
erlang-examples(x86-64) = R16B-02.3.fc19 is needed by (installed) erlang-R16B-02.3.fc19.x86_64

3. try to remove erlang
...

Actual results:
can't remove erlang without erlang-examples and vice versa

Expected results:
One of packages is possible to remove without any dependencies.

Additional info:
It's because of puppet, which removes packages through rpm command. There is no problem with removing through yum.