Bug 1038863

Summary: fedup F19 -> F20 can't start upgrade (missing systemd.unit=...)
Product: [Fedora] Fedora Reporter: Bruno Medeiros <brunojcm>
Component: fedupAssignee: Will Woods <wwoods>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 20CC: andrew, brunojcm, tflink, wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-01-17 16:46:50 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
'journalctl -b' after reboot to gdm using fedup grub entry
none
fedup log
none
grub2 config (full) none

Description Bruno Medeiros 2013-12-05 19:36:43 EST
Created attachment 833384 [details]
'journalctl -b' after reboot to gdm using fedup grub entry

Description of problem:
I'm trying to update from F19 to F20 using fedup, in a similar way to https://fedoraproject.org/wiki/QA:Testcase_upgrade_fedup_cli_previous_desktop. Fedup download phase is ok, but after reboot I get a GDM login screen, still on Fedora 19.

I'm reporting this bug booting from the fedup grub entry, my machine booted normally, as if I choose a normal grub entry. The fedup kernel is being used, though:

[root@brunojcm-fedora ~]# cat /proc/cmdline 
BOOT_IMAGE=/vmlinuz-fedup root=UUID=077370f6-d8b8-4be8-8cbb-2a13fb5244ac ro rootflags=subvol=rootfedora rd.md=0 rd.lvm=0 rd.dm=0 rd.luks=0 vconsole.font=latarcyrheb-sun16 vconsole.keymap=br-abnt2 rhgb quiet

Version-Release number of selected component (if applicable):
fedup 0.7.3-4.fc19

How reproducible: 
In my F19 install, always (without reinstall, just cleaning fedup).

Steps to Reproduce:
1. Install fedora 19 (maybe with all / on btrfs)
2. fedup --network 20 --instrepo http://dl.fedoraproject.org/pub/fedora/linux/development/20/x86_64/os/
3. reboot

Actual results:
Machine reboots to GDM, still F19

Expected results:
Upgrade completes.

Additional info:

GRUB entry:

menuentry 'Fedora, with Linux fedup' --class fedora --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-fedup-advanced-077370f6-d8b8-4be8-8cbb-2a13fb5244ac' {
        load_video
        insmod gzio
        insmod part_msdos
        insmod ext2
        set root='hd0,msdos4'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos4 --hint-efi=hd0,msdos4 --hint-baremetal=ahci0,msdos4 --hint='hd0,msdos4'  e0e1f20f-62c1-4415-87d5-b7884c719131
        else
          search --no-floppy --fs-uuid --set=root e0e1f20f-62c1-4415-87d5-b7884c719131
        fi
        linux   /vmlinuz-fedup root=UUID=077370f6-d8b8-4be8-8cbb-2a13fb5244ac ro rootflags=subvol=rootfedora rd.md=0 rd.lvm=0 rd.dm=0  rd.luks=0 vconsole.font=latarcyrheb-sun16 vconsole.keymap=br-abnt2 rhgb quiet 
        initrd  /initramfs-fedup.img
}
Comment 1 Bruno Medeiros 2013-12-05 19:38:06 EST
Created attachment 833385 [details]
fedup log
Comment 2 Bruno Medeiros 2013-12-05 19:41:39 EST
Created attachment 833386 [details]
grub2 config (full)
Comment 3 Will Woods 2013-12-06 13:44:57 EST
Your boot arguments don't have "systemd.unit=system-upgrade.target", which is how fedup 0.7.x started the upgrade. So something went weird there.

Before I try to figure that bug out, I've just built fedup-0.8.0, which shouldn't have this problem at all. Could you install this and try again?

  http://kojipkgs.fedoraproject.org/packages/fedup/0.8.0/1.fc19/noarch/fedup-0.8.0-1.fc19.noarch.rpm
Comment 4 Bruno Medeiros 2013-12-07 04:40:42 EST
> Your boot arguments don't have "systemd.unit=system-upgrade.target", which is how fedup 0.7.x started the upgrade. So something went weird there.

About this, I forgot to mention something. Following the advice on https://fedoraproject.org/wiki/FedUp#Executing_the_Upgrade, and considering that I installed Fedora after having an Ubuntu installed on the same machine, I reinstalled the grub just after running fedup (my main disk is really sda):
grub2-mkconfig -o /boot/grub2/grub.cfg
grub2-install /dev/sda

This might be causing the wrong grub entry on 0.7.x.

To test version 0.8.0 you suggested, I did the following:

wget http://kojipkgs.fedoraproject.org/packages/fedup/0.8.0/1.fc19/noarch/fedup-0.8.0-1.fc19.noarch.rpm
rpm -U fedup-0.8.0-1.fc19.noarch.rpm
fedup --clean
echo "" > /var/log/fedup.log
fedup --network 20 --instrepo http://dl.fedoraproject.org/pub/fedora/linux/development/20/x86_64/os/

Then I got something unrelated (I guess):

Downloading failed: Package systemd-libs-208-9.fc20.x86_64.rpm is not signed
Comment 5 Bruno Medeiros 2013-12-07 04:45:53 EST
The log says, to be more precise:

[    24.900] (II) fedup:message() Downloading failed: Package systemd-libs-208-9.fc20.x86_64.rpm is not signed
[    24.900] (DD) fedup:<module>() Traceback (for debugging purposes):
Traceback (most recent call last):
  File "/bin/fedup", line 236, in <module>
    main(args)
  File "/bin/fedup", line 159, in main
    pkgs = download_packages(f)
  File "/bin/fedup", line 80, in download_packages
    f.download_packages(updates, callback=output.DownloadCallback())
  File "/usr/lib/python2.7/site-packages/fedup/download.py", line 335, in download_packages
    self._checkSignatures(updates, callback)
  File "/usr/lib/python2.7/site-packages/fedup/download.py", line 474, in _checkSignatures
    raise yum.Errors.YumGPGCheckError(errmsg)
YumGPGCheckError: Package systemd-libs-208-9.fc20.x86_64.rpm is not signed
[    24.901] (II) fedup:<module>() /bin/fedup exiting cleanly at Sat Dec  7 07:39:22 2013
Comment 6 Bruno Medeiros 2013-12-07 05:11:41 EST
I tried again with "fedup --nogpgcheck ..." and the grub entry is the following:

menuentry 'System Upgrade (fedup)' --class fedora --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.11.9-200.fc19.x86_64-advanced-077370f6-d8b8-4be8-8cbb-2a13fb5244ac' {
        load_video
        set gfxpayload=keep
        insmod gzio
        insmod part_msdos
        insmod ext2
        set root='hd0,msdos4'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos4 --hint-efi=hd0,msdos4 --hint-baremetal=ahci0,msdos4 --hint='hd0,msdos4'  e0e1f20f-62c1-4415-87d5-b7884c719131
        else
          search --no-floppy --fs-uuid --set=root e0e1f20f-62c1-4415-87d5-b7884c719131
        fi
        linux   /vmlinuz-fedup root=UUID=077370f6-d8b8-4be8-8cbb-2a13fb5244ac ro rootflags=subvol=rootfedora rd.md=0 rd.lvm=0 rd.dm=0  rd.luks=0 vconsole.font=latarcyrheb-sun16 vconsole.keymap=br-abnt2 rhgb quiet
        initrd  /initramfs-fedup.img
}

Besides that, a few warnings. I message saying a few packages don't have update, amongst them kernel, yum, dbus and fedup itself.

Rebooting to test.
Comment 7 Bruno Medeiros 2013-12-07 05:23:50 EST
Upgrade worked, thank you very much!

If you want to see any logs, just ask me.
Comment 8 Andrew Wasielewski 2014-02-21 17:58:24 EST
I had exactly the same symptoms trying to fedup from F19 -> F20, even though I had the fedup 0.8.0 FC19 package.  See more info on Fedora Forums: http://www.forums.fedoraforum.org/showthread.php?p=1689696#post1689696.  

The missing "systemd.unit=system-upgrade.target" boot argument seems to have been the cause still, though I also had RAID-related issues that looked like they were fixed back in F17/18; I don't know if there is any relation between them.

Regards,
Andrew