Bug 1039364

Summary: No power management actions on laptop lid closed in tweak tools and general settings. Laptop screen still on when closing the lid
Product: [Fedora] Fedora Reporter: Rodrigo Paz <rodrigo.r.paz>
Component: gnome-power-managerAssignee: Richard Hughes <rhughes>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 20CC: emailtoflorian, gc, iskenderoguz, iweiss, rhughes, rodrigo.r.paz
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1114923 (view as bug list) Environment:
Last Closed: 2014-05-16 01:34:25 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Rodrigo Paz 2013-12-08 19:47:08 UTC
Description of problem:

I Upgraded Fedora 19 to Fedora 20 using FedUp. Then, I updated Fedora 20. On gnome-tweak-tools I have no options for actions when closing laptop lid. Also, there's no options on general settings for this issue. When I close the laptop lid the screen stays on. 

Version-Release number of selected component (if applicable):

kernel-3.11.10-300.fc20.x86_64
gnome-shell-3.10.2.1-2.fc20.x86_64
gnome-power-manager-3.10.1-1.fc20.x86_64
gnome-tweak-tool-3.10.1-2.fc20.noarch

How reproducible:
100%

Steps to Reproduce:
1. Update Fedora19 to Fedora 20 using FedUp.
2. Close laptop lid. Check the screen.
3. Verify power managment options in tweak tools and power general settings .

Actual results:
Screen is always on. 
No actions to take in power settings.

Expected results:
Suspend (or other actions) when closing the laptop lid.
Have options when setting the general power managment.

Additional info:

Comment 1 Rodrigo Paz 2013-12-10 05:56:37 UTC
(In reply to Rodrigo Paz from comment #0)
> Description of problem:
> 
> I Upgraded Fedora 19 to Fedora 20 using FedUp. Then, I updated Fedora 20. On
> gnome-tweak-tools I have no options for actions when closing laptop lid.
> Also, there's no options on general settings for this issue. When I close
> the laptop lid the screen stays on. 
> 
> Version-Release number of selected component (if applicable):
> 
> kernel-3.11.10-300.fc20.x86_64
> gnome-shell-3.10.2.1-2.fc20.x86_64
> gnome-power-manager-3.10.1-1.fc20.x86_64
> gnome-tweak-tool-3.10.1-2.fc20.noarch
> 
> How reproducible:
> 100%
> 
> Steps to Reproduce:
> 1. Update Fedora19 to Fedora 20 using FedUp.
> 2. Close laptop lid. Check the screen.
> 3. Verify power managment options in tweak tools and power general settings .
> 
> Actual results:
> Screen is always on. 
> No actions to take in power settings.
> 
> Expected results:
> Suspend (or other actions) when closing the laptop lid.
> Have options when setting the general power managment.
> 
> Additional info:


Problems persist after upgrading kernel and apps enabling updates-testing repo
i.e., kernel-3.11.10-301.fc20.x86_64

Comment 2 Rodrigo Paz 2013-12-21 02:42:55 UTC
I didn't know that 'suspend on closed lid' action settings will be off when going from F19 to F20, and the default behavior will be 'suspend'. Nevertheless, the automatic suspend action never worked in my laptop after upgrading and updating.
It is so annoying when I think that after upgrading from F19 using FedUp in my office, I closed the laptop lid, I packed it in my backpack and when I arrived home the laptop temperature was around 105C (220F). I almost lost my laptop because of a probably silly bug.
I these days I tried several approaches and nothing worked.

Comment 3 Giuseppe Castagna 2014-02-08 17:00:51 UTC
I agree it is very annoying that there is no setting for laptop lid. I would like to suspend the laptop if on battery and ignore the close-lid when plugged in.

Just as a temporary fix, have you tried to edit

/etc/systemd/logind.conf

by setting 

HandleLidSwitch=suspend

hope it helps

Comment 4 Rodrigo Paz 2014-02-08 20:28:29 UTC
Hi Giussepe,
thanks for your hint.
I tried your approach on every update since I posted the bug and it never worked. I started to think that probably it is a problem with the ati videocard driver, but it seems that nobody cares about this.
Thanks again,
Rodrigo

Comment 5 Ingo Weiss 2014-04-30 06:29:09 UTC
Hi Giuseppe, thanks for the tip. I worked.

If someone is wondering, this is what I get when running gnome-tweak-tool from the console:

--- ~ ยป gnome-tweak-tool 
INFO    : GSettings missing key org.gnome.settings-daemon.plugins.power (key lid-close-battery-action)
INFO    : GSettings missing key org.gnome.settings-daemon.plugins.power (key lid-close-ac-action)
INFO    : GSettings missing key org.gnome.settings-daemon.plugins.power (key lid-close-suspend-with-external-monitor)
WARNING : Error loading desktopfile: /home/ihoffmann/.config/autostart/xfce4-volumed.desktop
INFO    : GSettings missing key org.gnome.nautilus.desktop (key computer-icon-visible)