Bug 1040469

Summary: fuseiso: does not work on ppc64
Product: Red Hat Enterprise Linux 7 Reporter: Florian Weimer <fweimer>
Component: fuseisoAssignee: Zeeshan Ali <zali>
Status: CLOSED NOTABUG QA Contact: Red Hat Kernel QE team <kernel-qe>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 7.0CC: mclasen
Target Milestone: rc   
Target Release: ---   
Hardware: ppc64   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 864392 Environment:
Last Closed: 2013-12-11 15:32:48 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 864392    
Bug Blocks:    

Description Florian Weimer 2013-12-11 13:37:20 UTC
+++ This bug was initially created as a clone of Bug #864392 +++

Description of problem:

After fixing the endless loop in the command line parser (see patch), fuseiso still cannot mount any ISO images.

Version-Release number of selected component (if applicable):

fuseiso-20070708-12.el7.ppc64

How reproducible:


Steps to Reproduce:
1. fuseiso /path/to/image /mnt
2. ls -l /mnt
  
Actual results:

# fuseiso Fedora-17-x86_64-netinst.iso /mnt
isofs_read_raw_block: can`t read full block, read only 0 bytes from offset 0, 8 required; errno 0, message Success
isofs_read_raw_block: huh? reading zeros beyond file end? someone want to save a penny?
check_rr: directory record length too small: 0
isofs_read_raw_block: can`t read full block, read only 0 bytes from offset 0, 8 required; errno 0, message Success
isofs_read_raw_block: huh? reading zeros beyond file end? someone want to save a penny?
check_rr: directory record length too small: 0
# ls -l /mnt
ls: reading directory /mnt: Input/output error

Expected results:

Directory listing with the contents of the ISO image.

Comment 1 Zeeshan Ali 2013-12-11 14:29:23 UTC
Since this is required by Boxes mainly and that itself is exclusive to x86_64 arch on RHEL at least, I think the quickest and easiest way to resolve this is to not build fuseiso on ppc64. fuseiso has been unmaintained for years so we really should stop using it in Boxes soon any way.

Comment 2 Zeeshan Ali 2013-12-11 14:38:42 UTC
I can try to fix it but I'll need ACKs of course.

Comment 3 Florian Weimer 2013-12-11 14:39:31 UTC
(In reply to Zeeshan Ali from comment #1)
> Since this is required by Boxes mainly and that itself is exclusive to
> x86_64 arch on RHEL at least, I think the quickest and easiest way to
> resolve this is to not build fuseiso on ppc64. fuseiso has been unmaintained
> for years so we really should stop using it in Boxes soon any way.

Oh, I see it's already not built for RHEL 7.0.

(udisks2 offers similar functionality, so fuseiso really isn't needed.)