Bug 1043438

Summary: Eclipse crashed when I edit "java" file or others
Product: [Fedora] Fedora Reporter: ONURALP SEZER <thunderbirdtr>
Component: eclipseAssignee: Alexander Kurtakov <akurtako>
Status: CLOSED EOL QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 20CC: akurtako, andjrobins, buhrt, bulk, clarkaddison, jerboaa, mat.booth, mbenitez, mjenner, overholt, pschiffe, rgrunber, sgehwolf, sgilda, swagiaal, toigaras, turquino
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-06-29 09:32:48 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
java log from eclipse none

Description ONURALP SEZER 2013-12-16 05:28:02 EST
Created attachment 837195 [details]
java log from eclipse

Description of problem:

Eclipse crashes when I edit the java file or any other file inside of Eclipse
I'm developing android app inside eclipse but when I try to use normal java developing or android developing results are same.


Version-Release number of selected component (if applicable):

java-1.8.0-openjdk-demo-1.8.0.0-0.19.b106.fc20.x86_64
java-1.7.0-openjdk-1.7.0.60-2.4.3.0.fc20.x86_64
java-1.7.0-openjdk-headless-1.7.0.60-2.4.3.0.fc20.x86_64
java-1.7.0-openjdk-devel-1.7.0.60-2.4.3.0.fc20.x86_64h
java-1.8.0-openjdk-1.8.0.0-0.19.b106.fc20.x86_64
java-1.8.0-openjdk-javadoc-1.8.0.0-0.19.b106.fc20.noarch
java-1.8.0-openjdk-src-1.8.0.0-0.19.b106.fc20.x86_64


Eclipse version : 

eclipse-swt-4.3.1-11.fc20.x86_64
icu4j-eclipse-50.1.1-2.fc20.noarch
eclipse-platform-4.3.1-11.fc20.x86_64
eclipse-equinox-osgi-4.3.1-11.fc20.x86_64
eclipse-ecf-core-3.6.1-1.fc20.noarch
eclipse-emf-core-2.9.1-1.fc20.noarch

I'm using OpenJDK 1.7.0 and I tried with 1.8.0 also but still problem happened.
And I tried to open with terminal and It's created log file It's in alo attachment


How reproducible:
Open Eclipse and try to edit java file and crashed

Steps to Reproduce:
1.Open Eclipse
2.Open Project / or create project
3.Edit "java" file or any other programing language file
4.Crashed.

Actual results:
"Steps to Reproduce" part happen always

Expected results:
Open Eclipse and do development without problem.

Additional info:
Comment 1 Roland Grunberg 2014-01-02 15:06:34 EST
Does Eclipse crash when you try going into Help -> Help Contents ? Are you using the google-talkplugin on your system ?
Comment 2 ONURALP SEZER 2014-01-02 15:11:09 EST
I learnt later It was "google-talkplugin" problem shortly I can only use when I deleted. So we can close bug for this.
Comment 3 Roland Grunberg 2014-01-02 15:34:34 EST
As a workaround you can try adding '-Dorg.eclipse.swt.browser.DefaultType=mozilla' at the end of your /etc/eclipse.ini file. This isn't an ideal solution (Fedora Eclipse doesn't support xulrunner for rendering so the internal web browser won't be usable, and certain hover text might not be properly formatted) but it should stop the crashes, and allow you to keep google-talkplugin installed.

I don't believe we have a bug to track the issue caused by Eclipse (using webkitgtk) + google-talkplugin within Fedora so I don't mind keeping this open to track the progress.
Comment 4 ONURALP SEZER 2014-01-02 15:53:11 EST
I added to line started testing for Eclipse. Thank for info. Yes It's works fine for now. I will track it then If anything happen or any change I will write to here and give info(s) and so on then. 

Thank you.
Comment 5 Jeff Buhrt 2014-01-23 13:17:10 EST
See the F20 FAQ for this:
https://fedoraproject.org/wiki/Common_F20_bugs#eclipse-gtalk-crash

This ticket appears to be a duplicate of the problem in: https://bugzilla.redhat.com/show_bug.cgi?id=1040223

Another reference to this problem:
https://stackoverflow.com/questions/21134508/eclipse-crash-on-fedora-20/21297712#21297712

And at Eclipse.org:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=420974
Comment 6 hywel 2014-02-15 15:46:20 EST
(In reply to Roland Grunberg from comment #3)
> As a workaround you can try adding
> '-Dorg.eclipse.swt.browser.DefaultType=mozilla' at the end of your
> /etc/eclipse.ini file. This isn't an ideal solution (Fedora Eclipse doesn't
> support xulrunner for rendering so the internal web browser won't be usable,
> and certain hover text might not be properly formatted) but it should stop
> the crashes, and allow you to keep google-talkplugin installed.
> 
> I don't believe we have a bug to track the issue caused by Eclipse (using
> webkitgtk) + google-talkplugin within Fedora so I don't mind keeping this
> open to track the progress.

That solved the issue in my case
Comment 7 robberphex 2014-03-24 00:03:37 EDT
'-Dorg.eclipse.swt.browser.DefaultType=mozilla' cannot solved my problem.

By the way, it seems that google-talkplugin-5.1.5.0-1 can work with eclipse.(google-talkplugin has updated resent). is it?

if google-talkplugin-5.1.5.0-1 solved this problem, we can close this issue.
Comment 8 Jiri Zupka 2014-03-25 17:02:29 EDT
it hangs also with google-talkplugin-5.2.4.0
Comment 9 sgilda 2014-07-16 15:09:53 EDT
I am seeing this issue too.
Comment 10 Peter Schiffer 2014-08-20 18:17:04 EDT
I see this problem with blue jeans plugin installed:
bjnplugin-2.6.255.8-1.x86_64

google-talkplugin-5.4.2.0-1.x86_64 is OK for me.
Comment 11 Severin Gehwolf 2014-08-21 07:30:09 EDT
(In reply to Peter Schiffer from comment #10)
> I see this problem with blue jeans plugin installed:
> bjnplugin-2.6.255.8-1.x86_64

Funny that you mention this. I've installed the blue jeans plug-in yesterday and today I see *a lot* (3 times in the past 3 hours so far) F20 eclipse crashes.
Comment 12 Alexander Kurtakov 2014-08-21 07:33:43 EDT
Bluejeans is known to be a problem. I've reported this to bluejeans but nothing happened in the last few months. I recommend to Eclipse users to uninstall bluejeans or run SWT_GTK3=1 SWT_WEBKIT2=1 eclipse which will make eclipse use the experimental WEBKIT2 support which runs plugins out of process so the crash should not happen.
Comment 13 Severin Gehwolf 2014-08-21 07:47:35 EDT
(In reply to Alexander Kurtakov from comment #12)
> Bluejeans is known to be a problem. I've reported this to bluejeans but
> nothing happened in the last few months. I recommend to Eclipse users to
> uninstall bluejeans or run SWT_GTK3=1 SWT_WEBKIT2=1 eclipse which will make
> eclipse use the experimental WEBKIT2 support which runs plugins out of
> process so the crash should not happen.

Thanks for the heads-up Alex. Just to clarify, by "which runs plugins out of process" you mean which plugins that run out of process? eclipse plug-ins? webkit plug-ins? something else?
Comment 14 Alexander Kurtakov 2014-08-21 08:02:16 EDT
Sorry, I should have been clearer. Webkit2 runs its (webkit) plugins out of process so a crash in the webkit plugin should not crash the main webkit process.
Comment 15 Severin Gehwolf 2014-08-22 05:27:50 EDT
OK, so stock eclipse on F20 is 4.3 (Kepler). Using that with SWT_GTK3=1 is unusable[1]. I've been told there is a packaged eclipse Luna (4.4) using copr[2]. Thanks Mat! I gave that a whirl[3] and that seems to work OK (no more crashes with bluejeans installed). Last remaining issue is this upstream bug:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=439884


[1] http://i.imgur.com/AAszCiI.png
[2] http://copr.fedoraproject.org/coprs/mbooth/eclipse-luna/
[3] https://bugs.eclipse.org/bugs/show_bug.cgi?id=439884#c6
Comment 16 Mat Booth 2014-08-22 09:01:51 EDT
Thanks for linking to that, Severin, and thanks for giving a try!

I wrote up a blog about it here: http://mbooth101.github.io/eclipse-luna-for-fedora-20.html

One extra thing that is worth mentioning is that you may also need to change the "--launcher.GTK_version" option to 3 in your /opt/rh/eclipse-luna/root/etc/eclipse.ini file in order to get it running on GTK3.

I hope this helps someone!
Comment 17 Fedora End Of Life 2015-05-29 06:00:16 EDT
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 18 Fedora End Of Life 2015-06-29 09:32:48 EDT
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.