Bug 1045069

Summary: RFE: qemu:///session mode for root
Product: [Community] Virtualization Tools Reporter: Richard W.M. Jones <rjones>
Component: libvirtAssignee: Libvirt Maintainers <libvirt-maint>
Status: CLOSED DEFERRED QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: unspecifiedCC: berrange, clalancette, crobinso, itamar, jforbes, laine, libvirt-maint, mtenheuv, skuznets, veillard, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1045033 Environment:
Last Closed: 2020-11-03 16:37:59 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 910269, 890291, 1045033, 1045040, 1075300, 1375157, 1443955    

Description Richard W.M. Jones 2013-12-19 14:44:20 UTC
+++ This bug was initially created as a clone of Bug #1045033 +++

For context, see:
https://bugzilla.redhat.com/show_bug.cgi?id=1045033#c1

Libvirt doesn't offer session connections for root.
However people using libguestfs expect session-like
behaviour, even when they are doing stuff as root.  That
includes:

 - not polluting the system namespace with transient guests
   (virt-manager)

 - running qemu as root, not as qemu.qemu (see bug 1045040)

Therefore it would be good for libvirt to do the right
thing when given a qemu:///session URI when the client is
running as root.

Comment 1 Cole Robinson 2016-04-10 17:23:18 UTC
Still seems relevant: connecting to qemu:///session as root just silently connects to the system daemon it seems

Comment 2 Steve Kuznetsov 2016-10-13 18:44:32 UTC
Fiddling with permissions to make tools like virt-sysprep happy is frustrating, especially when the actions on the system are done with a framework like Ansible and therefore only ever using one user. It is surprising that the single user that ever interacted with the images, etc, has permissions issues since libvirt chooses to interact with images as user `qemu`.

Comment 3 Daniel Berrangé 2020-11-03 16:37:59 UTC
Thank you for reporting this issue to the libvirt project. Unfortunately we have been unable to resolve this issue due to insufficient maintainer capacity and it will now be closed. This is not a reflection on the possible validity of the issue, merely the lack of resources to investigate and address it, for which we apologise. If you none the less feel the issue is still important, you may choose to report it again at the new project issue tracker https://gitlab.com/libvirt/libvirt/-/issues The project also welcomes contribution from anyone who believes they can provide a solution.