Bug 1045871

Summary: yumdownloader --archlist=x86_64 downloads i686 on x86_64
Product: [Fedora] Fedora Reporter: Florian Hubold <doktor5000>
Component: yum-utilsAssignee: Packaging Maintenance Team <packaging-team-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 20CC: admiller, james.antill, jzeleny, opensource, packaging-team-maint, pmatilai, tla, vmukhame
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: yum-utils-1.1.31-23.fc20 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 470938 Environment:
Last Closed: 2014-06-11 16:28:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Florian Hubold 2013-12-22 17:42:21 UTC
+++ This bug was initially created as a clone of Bug #470938 +++

Description of problem:
When trying to download x86_64 packages and explicitly using --archlist=x86_64 it also downloads i686 packages.


Version-Release number of selected component (if applicable):
yum-3.4.3-122.fc20.noarch

How reproducible:
always

Steps to Reproduce:
(happens with any package except for noarch)

$ yumdownloader --archlist=x86_64 qt5-qttools
[snip]
(1/2): qt5-qttools-5.2.0-0.10.rc1.fc20.i686.rpm                                                                                                         | 3.8 MB  00:00:01     
(2/2): qt5-qttools-5.2.0-0.10.rc1.fc20.x86_64.rpm                                                                                                       | 3.8 MB  00:00:03
  
Actual results:
It downloads the package for all architectures available from repos.


Expected results:
It should only download the x86_64 package, as per the documentation:

$ yumdownloader | grep -A1 archlist
    --archlist=ARCHLIST
                        only download packages of certain architecture(s)

Comment 1 Florian Hubold 2013-12-22 18:12:14 UTC
FWIW, using yum reinstall qt5-qttools --downloadonly --downloaddir=. it works as expected, but probably just because only the x86_64 package is installed.

Also tried to explicitly set the basearch as proposed the original bug seems to suggest via:

yum-config-manager --save --setopt=basearch=x86_64

But that has no effect, also manpage of yum.conf doesn't mention either setarch or basearch, only $basearch as variable for repo configuration, so this is probably no valid setting at all.

Comment 2 Valentina Mukhamedzhanova 2014-03-11 16:54:32 UTC
Hello Florian, the documentation is actually inaccurate here, --archlist limits architectures to the given and all compatible with the given. I have fixed the documentation upstream. For your use case please use the following command:

yumdownloader -x \*i686 --archlist=x86_64 qt5-qttools

Comment 3 Florian Hubold 2014-03-12 21:32:58 UTC
Hi Valentina,

thanks for the hint, will certainly try that :)

Would my assumption be correct, that on x86_64 it would be enough to simply exclude i686, without using --archlist at all?

Comment 4 Valentina Mukhamedzhanova 2014-03-13 09:48:34 UTC
You might also want to exclude these arches: athlon, i586, i486, i386, noarch, because they all are compatible with x86_64.

Comment 5 Fedora Update System 2014-05-22 14:24:18 UTC
yum-utils-1.1.31-22.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/yum-utils-1.1.31-22.fc20

Comment 6 Fedora Update System 2014-05-24 23:25:00 UTC
Package yum-utils-1.1.31-23.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yum-utils-1.1.31-23.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-6637/yum-utils-1.1.31-23.fc20
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2014-06-11 16:28:38 UTC
yum-utils-1.1.31-23.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.