Bug 1047040

Summary: Add IPv6 Support to fail2ban
Product: [Fedora] Fedora EPEL Reporter: Mike Bretz <mike>
Component: fail2banAssignee: Orion Poplawski <orion>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: el6CC: admiller, orion, rhbugs, vonsch
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
URL: https://github.com/fail2ban/fail2ban/pull/469
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-07-21 22:54:56 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mike Bretz 2013-12-28 17:06:35 UTC
Description of problem:

An increasing number of large providers (at least in germany) are assigning IPv6 addresses to newly assigned hosts. That's why fail2ban should get IPv6 Support as well, so tracking & banning will work with v6 addresses too.

Actual results:
  No IPv6 support, a possible hack attempt from ipv6 addresses will be unnoticed by fail2ban. (as of 0.8.11-2.el6)

Expected results:
  IPv6 support is available and working.

Additional info:

Please see for a possible patch at http://www.fail2ban.org/wiki/index.php/Fail2ban:Community_Portal#IPv6_Experimental_support
Even if marked as "experimental" it is working well, and solution is "easy" to migrate into package.

This might (partly) be related, but unmodified since 2012-03  https://bugzilla.redhat.com/show_bug.cgi?id=800694