Bug 1047635

Summary: fedora-upgrade (F19 -> F20) did not (completely?) update VirtualBox
Product: [Fedora] Fedora Reporter: Jeffrey Walton <noloader>
Component: fedora-upgradeAssignee: Miroslav Suchý <msuchy>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: 20CC: cheese, msuchy
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-11-25 00:24:23 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jeffrey Walton 2014-01-01 11:47:49 UTC
After upgrading from Fedora 19 to Fedora 20 using `fedora-upgrade` per https://fedoraproject.org/wiki/Upgrading_Fedora_using_yum, I ran `package-cleanup --orphans` to find packages that were not upgraded. The following were not upgraded:

* kernel-3.11.10-200.fc19.x86_64
* kernel-3.12.5-200.fc19.x86_64
* kernel-modules-extra-3.11.10-200.fc19.x86_64
* kernel-modules-extra-3.12.5-200.fc19.x86_64
* kmod-VirtualBox-3.12.5-200.fc19.x86_64-4.3.6-1.fc19.1.x86_64

A subsequent `yum remove kmod-VirtualBox-3.12.5-200.fc19.x86_64-4.3.6-1.fc19.1.x86_64` resulted in a removal of VirtualBox.

VirtualBox was reinstalled using `yum install VirtualBox`, but with a different driver (see below).

Something seems mildly astray since an orphaned F19 component removed VirtualBox on F20. I would have expected a VirtualBox upgrade with the rest of the system; or a good package dependecy graph so VirtualBox would remain.

*****

# yum install VirtualBox
Loaded plugins: langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package VirtualBox.x86_64 0:4.3.6-3.fc20 will be installed
--> Processing Dependency: VirtualBox-kmod = 4.3.6 for package: VirtualBox-4.3.6-3.fc20.x86_64
--> Running transaction check
---> Package kmod-VirtualBox-3.12.5-302.fc20.x86_64.x86_64 0:4.3.6-1.fc20.1 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                     Arch   Version        Repository              Size
================================================================================
Installing:
 VirtualBox                  x86_64 4.3.6-3.fc20   rpmfusion-free-updates  29 M
Installing for dependencies:
 kmod-VirtualBox-3.12.5-302.fc20.x86_64
                             x86_64 4.3.6-1.fc20.1 rpmfusion-free-updates 208 k

Transaction Summary
================================================================================
Install  1 Package (+1 Dependent package)

Total download size: 30 M
Installed size: 90 M
Is this ok [y/d/N]: Y
Downloading packages:
(1/2): kmod-VirtualBox-3.12.5-302.fc20.x86_64-4.3.6-1.fc20 | 208 kB   00:00     
(2/2): VirtualBox-4.3.6-3.fc20.x86_64.rpm                  |  29 MB   00:18     
--------------------------------------------------------------------------------
Total                                              1.6 MB/s |  30 MB  00:18     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : VirtualBox-4.3.6-3.fc20.x86_64                               1/2 
  Installing : kmod-VirtualBox-3.12.5-302.fc20.x86_64-4.3.6-1.fc20.1.x86_   2/2 
  Verifying  : kmod-VirtualBox-3.12.5-302.fc20.x86_64-4.3.6-1.fc20.1.x86_   1/2 
  Verifying  : VirtualBox-4.3.6-3.fc20.x86_64                               2/2 

Installed:
  VirtualBox.x86_64 0:4.3.6-3.fc20                                              

Dependency Installed:
  kmod-VirtualBox-3.12.5-302.fc20.x86_64.x86_64 0:4.3.6-1.fc20.1                

Complete!

Comment 1 Miroslav Suchý 2014-11-25 00:24:23 UTC
kmod is kernel module. And fedora keeps 2 last kernels (in case one fail, you can boot to another). Therefore keeping fc19 kernel (and its modules) is fine and expected.