Bug 1051405

Summary: inscript2 layouts are not supported in ibus-typing-booster
Product: [Fedora] Fedora Reporter: Amandeep Singh Saini <asaini>
Component: ibus-typing-boosterAssignee: Mike FABIAN <mfabian>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: ankit, apatil, i18n-bugs, mfabian, psatpute
Target Milestone: ---Keywords: i18n, Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: ibus-typing-booster-1.2.9-1.fc19 ibus-typing-booster-1.3.0-3.fc23 ibus-typing-booster-1.3.0-3.fc22 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-12-22 22:03:00 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 772665    
Bug Blocks:    

Description Amandeep Singh Saini 2014-01-10 08:54:38 UTC
Description of problem:
inscript 2 is enhanced version of inscript layout but it is not supported in ibus-typing-booster


Version-Release number of selected component (if applicable):
ibus-typing-booster-1.2.7-1.fc19.noarch


How reproducible:
everytime

Steps to Reproduce:
1. try to select inscript 2 punjabi from regional and language settings
2. 
3.

Actual results:
inscript 2 not available

Expected results:
it should be there

Additional info:

Comment 1 Pravin Satpute 2014-01-10 09:06:17 UTC
Inscript2 layouts needed AltGr support, hence depends on bug #772665

Comment 2 Fedora Update System 2014-01-17 16:25:43 UTC
ibus-typing-booster-1.2.9-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/ibus-typing-booster-1.2.9-1.fc20

Comment 3 Fedora Update System 2014-01-17 16:27:14 UTC
ibus-typing-booster-1.2.9-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ibus-typing-booster-1.2.9-1.fc19

Comment 4 Fedora Update System 2014-01-18 04:25:06 UTC
Package ibus-typing-booster-1.2.9-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-typing-booster-1.2.9-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-1061/ibus-typing-booster-1.2.9-1.fc19
then log in and leave karma (feedback).

Comment 5 Pravin Satpute 2014-01-22 05:54:53 UTC
(In reply to Pravin Satpute from comment #1)
> Inscript2 layouts needed AltGr support, hence depends on bug #772665

Thanks Mike. This is working fine now. I can see Enhanced inscript layout listed in setting for IME.

But Enhanced inscript requires AltGr mapping. So we need to fix that as well. I will update instruction for reproducing on dependant bug.

Comment 6 Fedora Update System 2014-01-29 03:04:19 UTC
ibus-typing-booster-1.2.9-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2014-01-29 03:08:57 UTC
ibus-typing-booster-1.2.9-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Mike FABIAN 2015-12-15 21:22:46 UTC
This is not really fixed because AltGr is ignored in ibus-typing-booster
at the moment and most inscript2 input methods use AltGr quite a lot.

mfabian@ari:/usr/share/m17n
$ grep G- mr-inscript2.mim 
  ((G-1) "‍")
  ((G-2) "‌")
  ((G-4) "₹")
  ((G-+) "ॠ")
  ((G-=) "ॄ")
  ((G-e) "॑")
  ((G-R) "ॡ")
  ((G-r) "ॣ")
  ((G-d) "॒")
  ((G-F) "ऌ")
  ((G-f) "ॢ")
  ((G-X) "ॐ")
  ((G-,) "॰")
  ((G->) "ऽ")
  ((G-.) "॥")
mfabian@ari:/usr/share/m17n
$

Comment 9 Fedora Update System 2015-12-17 12:26:01 UTC
ibus-typing-booster-1.3.0-3.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-10ffd394ce

Comment 10 Fedora Update System 2015-12-17 12:26:50 UTC
ibus-typing-booster-1.3.0-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-fefee286e1

Comment 11 Fedora Update System 2015-12-18 11:27:04 UTC
ibus-typing-booster-1.3.0-3.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update ibus-typing-booster'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-10ffd394ce

Comment 12 Fedora Update System 2015-12-18 11:55:52 UTC
ibus-typing-booster-1.3.0-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update ibus-typing-booster'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-fefee286e1

Comment 13 Fedora Update System 2015-12-22 22:02:51 UTC
ibus-typing-booster-1.3.0-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2016-01-09 02:20:56 UTC
ibus-typing-booster-1.3.0-3.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.