Bug 1054763

Summary: v8 collection needs to be enabled by user in order to use rubyracer gem
Product: Red Hat Software Collections Reporter: Miroslav Hradílek <mhradile>
Component: doc-Release_NotesAssignee: Lenka Špačková <lkuprova>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: ruby200CC: jhradile
Target Milestone: ---   
Target Release: 1.1   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Release Note
Doc Text:
Previously, in Red Hat Software Collections 1.0, the V8 JavaScript engine was part of the ruby193 Software Collection. In Red Hat Software Collections 1.1, the v8 packages have been replaced by the v8314 Software Collection, which is installed as a dependency. In order to use therubyracer, it is necessary to enable the v8314 Software Collection as well.
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-06-10 09:00:45 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Miroslav Hradílek 2014-01-17 12:32:28 UTC
Description of problem:

In RHSCL 1.0 v8 javascript engine was part of the ruby collections. With RHSCL 1.1, v8 packages were replaced by separate v8314 collection installed as a dependency. Thius means that in order to use rubyracer the user is obliged to enable v8 collection as well. Otherwise he can expect only error.

Comment 2 Miroslav Hradílek 2014-01-23 11:21:56 UTC
*** Bug 1054220 has been marked as a duplicate of this bug. ***

Comment 3 Miroslav Hradílek 2014-02-24 09:29:08 UTC
Sounds fine.