Bug 1055220

Summary: SELinux is preventing /usr/bin/Xorg from 'read' accesses on the chr_file urandom.
Product: [Fedora] Fedora Reporter: Zero <HolyMaster>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 20CC: dominick.grift, dwalsh, lvrabec, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:eb71be212a9cd16b1f361218eee94814b1351206ea26e1e81f22813bea61dd17
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-01-19 18:26:01 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Zero 2014-01-19 15:49:53 UTC
Description of problem:
SELinux is preventing /usr/bin/Xorg from 'read' accesses on the chr_file urandom.

*****  Plugin catchall_boolean (89.3 confidence) suggests   ******************

If you want to allow global to ssp
Then you must tell SELinux about this by enabling the 'global_ssp' boolean.
You can read 'None' man page for more details.
Do
setsebool -P global_ssp 1

*****  Plugin catchall (11.6 confidence) suggests   **************************

If you believe that Xorg should be allowed read access on the urandom chr_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep Xorg /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:bumblebee_t:s0
Target Context                system_u:object_r:urandom_device_t:s0
Target Objects                urandom [ chr_file ]
Source                        Xorg
Source Path                   /usr/bin/Xorg
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           xorg-x11-server-Xorg-1.14.4-5.fc20.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-106.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.12.7-300.fc20.x86_64 #1 SMP Fri
                              Jan 10 15:35:31 UTC 2014 x86_64 x86_64
Alert Count                   10
First Seen                    2014-01-14 13:27:13 CET
Last Seen                     2014-01-16 14:31:45 CET
Local ID                      de95d763-5ca8-4916-805d-3c08bdd38687

Raw Audit Messages
type=AVC msg=audit(1389879105.66:437): avc:  denied  { read } for  pid=2664 comm="Xorg" name="urandom" dev="devtmpfs" ino=1033 scontext=system_u:system_r:bumblebee_t:s0 tcontext=system_u:object_r:urandom_device_t:s0 tclass=chr_file


type=AVC msg=audit(1389879105.66:437): avc:  denied  { open } for  pid=2664 comm="Xorg" path="/dev/urandom" dev="devtmpfs" ino=1033 scontext=system_u:system_r:bumblebee_t:s0 tcontext=system_u:object_r:urandom_device_t:s0 tclass=chr_file


type=SYSCALL msg=audit(1389879105.66:437): arch=x86_64 syscall=open success=yes exit=EISDIR a0=7f08079e6b6d a1=0 a2=1b6 a3=0 items=0 ppid=493 pid=2664 auid=4294967295 uid=0 gid=1001 euid=0 suid=0 fsuid=0 egid=1001 sgid=1001 fsgid=1001 ses=4294967295 tty=(none) comm=Xorg exe=/usr/bin/Xorg subj=system_u:system_r:bumblebee_t:s0 key=(null)

Hash: Xorg,bumblebee_t,urandom_device_t,chr_file,read

Additional info:
reporter:       libreport-2.1.11
hashmarkername: setroubleshoot
kernel:         3.12.7-300.fc20.x86_64
type:           libreport

Comment 1 Miroslav Grepl 2014-01-19 18:26:01 UTC

*** This bug has been marked as a duplicate of bug 1055211 ***