Bug 1056270

Summary: problem with if '://' in pkg syntax
Product: [Fedora] Fedora Reporter: Fabrice Bellet <fabrice>
Component: createrepoAssignee: Packaging Maintenance Team <packaging-team-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 20CC: fykcee1, kevin, lmacken, packaging-team-maint, zpavlas
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: createrepo-0.10.3-1.fc20 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-01-29 09:36:08 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Fabrice Bellet 2014-01-21 20:34:53 UTC
Hi!

On my local koji infrastructure, where I use mergerepos and createrepo to deal with external repositories, I found this error when running koji regen-repo:

Traceback (most recent call last):
  File "/usr/libexec/kojid/mergerepos.orig", line 262, in <module>
    main(sys.argv[1:])
  File "/usr/libexec/kojid/mergerepos.orig", line 257, in main
    merge.write_metadata()
  File "/usr/libexec/kojid/mergerepos.orig", line 237, in write_metadata
    mdgen.doPkgMetadata()
  File "/usr/lib/python2.7/site-packages/createrepo/__init__.py", line 406, in doPkgMetadata
    if '://' in pkg: # remote
  File "/usr/lib/python2.7/site-packages/yum/packages.py", line 384, in __getitem__
    return getattr(self, key)
TypeError: getattr(): attribute name must be string

Downgrading to version 0.9.9-23.fc20 fixes this error (there's no iteration to search for :// in the pkg name)

Comment 1 Kevin Fenzi 2014-01-28 21:34:31 UTC
Seeing this here in fedora koji too. ;(

Comment 2 Zdeněk Pavlas 2014-01-29 09:36:08 UTC

*** This bug has been marked as a duplicate of bug 1058975 ***

Comment 3 Mike McLean 2014-02-26 22:42:10 UTC
*** Bug 1046456 has been marked as a duplicate of this bug. ***