Bug 1057281

Summary: [DWH-SETUP] - remote user password is asked twice for authentication
Product: Red Hat Enterprise Virtualization Manager Reporter: rhev-integ
Component: ovirt-engine-dwhAssignee: Yedidyah Bar David <didi>
Status: CLOSED ERRATA QA Contact: Barak Dagan <bdagan>
Severity: medium Docs Contact:
Priority: low    
Version: unspecifiedCC: aberezin, acathrow, adahms, bazulay, gklein, iheim, pstehlik, Rhev-m-bugs, sbonazzo, yeylon, ylavi, zdover
Target Milestone: ---Keywords: ZStream
Target Release: 3.3.1   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: integration
Fixed In Version: rhevm-dwh-3.3.1-1.el6ev.noarch.rpm Doc Type: Bug Fix
Doc Text:
Previously, users were asked to provide their passwords twice when running ovirt-engine-dwh-setup with a remote database. Now, users are only asked to provide their password one time.
Story Points: ---
Clone Of: 1040938 Environment:
Last Closed: 2014-03-03 13:18:39 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1040938    
Bug Blocks:    

Comment 2 Barak Dagan 2014-02-06 17:30:09 UTC
Verified on is34.1 (rhevm-dwh-3.3.1-1.el6ev.noarch):

Welcome to ovirt-engine-dwh setup utility

In order to proceed the installer must stop the ovirt-engine service
Would you like to stop the ovirt-engine service (yes|no): yes
Stopping ovirt-engine...                              [ DONE ]
Remote installation is selected.

Remote installation selected. Make sure that DBA creates a user and the database in the following fashion:
	create role <role> with login encrypted password <password>;
	create database ovirt_engine_history template template0 encoding 'UTF8' lc_collate 'en_US.UTF-8' lc_ctype 'en_US.UTF-8' owner <role>;

Database user [engine_history]: remoteuser
Database password: 
Creating DB Schema...                                 [ DONE ]

Comment 4 errata-xmlrpc 2014-03-03 13:18:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0243.html