Bug 1057999

Summary: PRD34 - [RFE] qemu-ga installed by default on Linux Guests with ovirt-guest-agent
Product: Red Hat Enterprise Virtualization Manager Reporter: Itamar Heim <iheim>
Component: ovirt-guest-agentAssignee: Vinzenz Feenstra [evilissimo] <vfeenstr>
Status: CLOSED ERRATA QA Contact: Jiri Belka <jbelka>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 3.4.0CC: acathrow, gklein, iheim, lbopf, michal.skrivanek, mkenneth, Rhev-m-bugs, sbonazzo, sherold, vfeenstr, yeylon
Target Milestone: ---Keywords: FutureFeature
Target Release: 3.4.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: virt
Fixed In Version: rhevm-guest-agent-1.0.8-8.el6_5 Doc Type: Enhancement
Doc Text:
To support freezing and thawing the file systems, qemu-guest-agent is now installed by default on Linux guests with ovirt-guest-agent.
Story Points: ---
Clone Of: 1055524 Environment:
Last Closed: 2014-06-09 13:30:58 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1055524    
Bug Blocks: 1078909, 1142926    
Attachments:
Description Flags
Proposed patch to depend on the qemu guest agent none

Description Itamar Heim 2014-01-26 11:45:36 UTC
+++ This bug was initially created as a clone of Bug #1055524 +++

In order to support https://bugzilla.redhat.com/show_bug.cgi?id=1054231 we need to add the qemu-guest-agent by default to support freezing and thawing the filesystems.

The guest agent will implement a dependency on the package so it is installed when the ovirt-guest-agent is installed.

--- Additional comment from Vinzenz Feenstra [evilissimo] on 2014-01-20 09:30:05 EST ---

Merged to u/s master as http://gerrit.ovirt.org/gitweb?p=ovirt-guest-agent.git;a=commit;h=52b97cfbd5f1a4378b0be168ffd8293e29f99f46

--- Additional comment from Sandro Bonazzola on 2014-01-23 03:54:39 EST ---

Verified using http://evilissimo.fedorapeople.org/repos/ovirt-guest-agent/ovirt-3.4/beta1/
on CentOS 6.5, Fedora 19 and Fedora 20.

Comment 1 Vinzenz Feenstra [evilissimo] 2014-02-04 08:45:11 UTC
Created attachment 858954 [details]
Proposed patch to depend on the qemu guest agent

Comment 3 Jiri Belka 2014-02-06 13:49:21 UTC
Does it mean RH will improve QGA so it can do some usable things or we will have just more guest agents? :)

In QGA source there's many 'unsupported' comments for features right now.

Comment 5 Jiri Belka 2014-02-12 13:58:27 UTC
ok

...
Installed:
  rhevm-guest-agent-common.noarch 0:1.0.8-8.el6_5                                                                                                
Dependency Installed:
  qemu-guest-agent.x86_64 2:0.12.1.2-2.415.el6_5.3

Comment 6 errata-xmlrpc 2014-06-09 13:30:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0655.html