Bug 1058121

Summary: [whql][netkvm]win2k8-32 BSOD with 7E code when run WLK job "Ethernet - NDISTest 6.5 (MPE)"
Product: Red Hat Enterprise Linux 7 Reporter: lijin <lijin>
Component: virtio-winAssignee: Yan Vugenfirer <yvugenfi>
Status: CLOSED ERRATA QA Contact: Virtualization Bugs <virt-bugs>
Severity: high Docs Contact:
Priority: high    
Version: 7.0CC: dfleytma, knoel, michen, rbalakri, virt-maint, vrozenfe, yvugenfi
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
NO_DOCS
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-11-24 08:39:48 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description lijin 2014-01-27 04:25:39 UTC
Created attachment 855900 [details]
win2k8-32-netkvm-1.6.7-2-hck-log

Description of problem:
win2k8-32 BSOD with code 7E when run WLK job "Ethernet - NDISTest 6.5 (MPE)"

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-1.5.3-30.el7.x86_64
kernel-3.10.0-64.el7.x86_64
seabios-1.7.2.2-7.el7.x86_64
virtio-win-prewhql-1.6.7-2

How reproducible:
1/5

Steps to Reproduce:
1.boot guest with:
nic1:
/usr/libexec/qemu-kvm -m 6G -M pc -smp 8,cores=8 -cpu SandyBridge,hv_spinlocks=0x1fff,hv_relaxed,hv_vapic -usb -device usb-tablet -drive file=win2k8-32-nic1.raw,format=raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -uuid b225ae8b-d9dd-4976-9a66-2e76c87fb24a -rtc-td-hack -no-kvm-pit-reinjection -rtc base=localtime,clock=host,driftfix=slew -chardev socket,id=a11,path=/tmp/monitor-win2k8-32-netkvm-1.6.7-2,server,nowait -mon chardev=a11,mode=readline -vnc :13 -vga cirrus -chardev socket,id=channel0,path=/tmp/tt,server,nowait -name win2k8-32-netkvm-1.6.7-2-nic1 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -monitor stdio -cdrom /usr/share/virtio-win/virtio-win.iso -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:52:a2:e2:92:22 -netdev tap,sndbuf=0,id=hostnet1,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet1,mac=00:52:a2:e2:92:23 -netdev tap,sndbuf=0,id=hostnet2,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio

nic2:
/usr/libexec/qemu-kvm -m 2G -M pc -smp 2,cores=2 -cpu SandyBridge,hv_spinlocks=0x1fff,hv_relaxed,hv_vapic -usb -device usb-tablet -drive file=win2k8-32-nic2.raw,format=raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -uuid e22c777b-76ff-4c74-bca8-e43c9067b1e3 -rtc-td-hack -no-kvm-pit-reinjection -rtc base=localtime,clock=host,driftfix=slew -chardev socket,id=a11,path=/tmp/monitor-win2k8R2-netkvm-1.6.7-2,server,nowait -mon chardev=a11,mode=readline -vnc :14 -vga cirrus -chardev socket,id=channel0,path=/tmp/tt,server,nowait -name win2k8-32-netkvm-1.6.7-2-nic2 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -monitor stdio -cdrom /usr/share/virtio-win/virtio-win.iso -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:23:a8:e0:e1:e2 -netdev tap,sndbuf=0,id=hostnet1,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet1,mac=00:23:a8:29:90:91-net-pci,netdev=hostnet2,mac=00:52:a2:71:93:13
2.submit jobs in WLK

Actual results:
guest BSOD with 7E code,job failed

Expected results:
job can pass,no BSOD

Additional info:
guest also bsod with 9F code,report bug 1058115 to track it.

Comment 1 lijin 2014-01-27 04:26:43 UTC
dump file debug info:
3: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

SYSTEM_THREAD_EXCEPTION_NOT_HANDLED (7e)
This is a very common bugcheck.  Usually the exception address pinpoints
the driver/function that caused the problem.  Always note this address
as well as the link date of the driver/image that contains this address.
Arguments:
Arg1: 80000003, The exception code that was not handled
Arg2: 81913b73, The address that the exception occurred at
Arg3: 978d9bcc, Exception Record Address
Arg4: 978d98c8, Context Record Address

Debugging Details:
------------------


EXCEPTION_CODE: (HRESULT) 0x80000003 (2147483651) - One or more arguments are invalid

FAULTING_IP: 
nt!DbgPrompt+46
81913b73 cc              int     3

EXCEPTION_RECORD:  978d9bcc -- (.exr 0xffffffff978d9bcc)
ExceptionAddress: 81913b73 (nt!DbgPrompt+0x00000046)
   ExceptionCode: 80000003 (Break instruction exception)
  ExceptionFlags: 00000000
NumberParameters: 3
   Parameter[0]: 00000002
   Parameter[1]: 945045b8
   Parameter[2]: 00000044

CONTEXT:  978d98c8 -- (.cxr 0xffffffff978d98c8)
eax=00000002 ebx=978d9cd8 ecx=945045b8 edx=00000044 esi=945045b9 edi=00000002
eip=81913b73 esp=978d9c94 ebp=978d9cb0 iopl=0         nv up ei pl nz na pe nc
cs=0008  ss=0010  ds=0023  es=0023  fs=0030  gs=0000             efl=00000206
nt!DbgPrompt+0x46:
81913b73 cc              int     3
Resetting default scope

DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

BUGCHECK_STR:  0x7E

PROCESS_NAME:  System

CURRENT_IRQL:  0

ERROR_CODE: (NTSTATUS) 0x80000003 - {EXCEPTION}  Breakpoint  A breakpoint has been reached.

EXCEPTION_PARAMETER1:  00000002

EXCEPTION_PARAMETER2:  945045b8

EXCEPTION_PARAMETER3:  00000044

LAST_CONTROL_TRANSFER:  from 94491a34 to 81913b73

STACK_TEXT:  
978d9cb0 94491a34 945045b8 978d9cd8 00000002 nt!DbgPrompt+0x46
WARNING: Stack unwind information not available. Following frames may be wrong.
978d9ce4 944b0834 00000001 945103d8 00000156 ndprot60+0x55a34
978d9d08 944b1990 00000001 000dbba0 9716c2e0 ndprot60+0x74834
978d9d68 944e3c00 00000000 927ad534 927ad550 ndprot60+0x75990
978d9d7c 81a0cc42 927ad550 9e17cb25 00000000 ndprot60+0xa7c00
978d9dc0 81875efe 944e3bc0 927ad550 00000000 nt!PspSystemThreadStartup+0x9d
00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x16


FOLLOWUP_IP: 
ndprot60+55a34
94491a34 8b4de8          mov     ecx,dword ptr [ebp-18h]

SYMBOL_STACK_INDEX:  1

SYMBOL_NAME:  ndprot60+55a34

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: ndprot60

IMAGE_NAME:  ndprot60.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  4d4be8f5

STACK_COMMAND:  .cxr 0xffffffff978d98c8 ; kb

FAILURE_BUCKET_ID:  0x7E_VRF_ndprot60+55a34

BUCKET_ID:  0x7E_VRF_ndprot60+55a34

Followup: MachineOwner
---------

Comment 16 lijin 2015-02-03 07:41:45 UTC
test with virtio-win-prewhql-100,2k8-32/64 guests passed the job "Ethernet - NDISTest 6.5 (MPE)",no bsod,no error

package info:
    virtio-win-prewhql-0.1-100
    qemu-kvm-rhev-2.1.2-20.el7.x86_64
    kernel-3.10.0-223.el7.x86_64
    seabios-1.7.5-7.el7.x86_64
    spice-server-0.12.4-9.el7.x86_64

Comment 17 Mike Cao 2015-02-03 07:43:50 UTC
Move to Verified status according to comment#16.

Comment 20 errata-xmlrpc 2015-11-24 08:39:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2513.html