Bug 1059194

Summary: Missing rebase: ACTION_UPGRADE is not available on 3.4
Product: Red Hat Enterprise Virtualization Manager Reporter: Ohad Basan <obasan>
Component: rhevm-setup-pluginsAssignee: Alon Bar-Lev <alonbl>
Status: CLOSED ERRATA QA Contact: Jiri Belka <jbelka>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 3.4.0CC: acathrow, alonbl, bazulay, eedri, gklein, iheim, pstehlik, Rhev-m-bugs, sbonazzo, scohen, tpoitras, yeylon
Target Milestone: ---   
Target Release: 3.4.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: integration
Fixed In Version: ovirt-3.4.0-beta3 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-06-09 13:31:25 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1078909, 1142926    

Description Ohad Basan 2014-01-29 12:09:51 UTC
Description of problem:
a rebase patch has to be added to remove the ACTION_UPGRADE parameter from upstream code

currently rhev 3.4 setup fails on 
2014-01-29 11:37:04 DEBUG otopi.context context._executeMethod:152 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/otopi/context.py", line 142, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/distro-rhel/showupgradekb.py", line 55, in _init
    ] == osetupcons.Const.ACTION_UPGRADE and
AttributeError: type object 'Const' has no attribute 'ACTION_UPGRADE'
2014-01-29 11:37:04 ERROR otopi.context context._executeMethod:161 Failed to execute stage 'Initializing': type object 'Const' has no attribute 'ACTION_UPGRADE'

Comment 1 Alon Bar-Lev 2014-01-29 12:11:38 UTC
funny I just working on this.
please do not open any more bugs on rhevm-setup-plugins for 3.4 until I resolve all.

Comment 2 Alon Bar-Lev 2014-01-29 12:13:33 UTC
commit 01c2b0578a9633328ca72dd53dd4f3fd9cb2a055
Author: Alon Bar-Lev <alonbl@redhat.com>
Date:   Wed Jan 29 13:59:50 2014 +0200

    distro-rhel: remove showupgradekb
    
    it relays on obsolete LEGACY upgrade and obsolete ACTION.
    
    if required we add it properly somehow.
    
    not sure we need to warn user any more.
    
    Change-Id: Idd685d1c954311b1acf7ca48803b6c78acf3a60c
    Signed-off-by: Alon Bar-Lev <alonbl@redhat.com>

Comment 4 Jiri Belka 2014-02-19 15:52:23 UTC
What has to be verified here? Thank you.

Comment 5 Alon Bar-Lev 2014-02-19 15:54:19 UTC
(In reply to Jiri Belka from comment #4)
> What has to be verified here? Thank you.

nothing. this bug was opened for something that should not have been tested.
if engine-setup works for you all ok.

Comment 7 Jiri Belka 2014-02-25 09:07:20 UTC
ok, on upstream 'beta3', rhevm specific stuff does not exist.

Comment 9 errata-xmlrpc 2014-06-09 13:31:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0653.html