Bug 1059897

Summary: Support 64-bit /SYM64/ symbol table
Product: Red Hat Enterprise Linux 6 Reporter: Ed Santiago <santiago>
Component: elfutilsAssignee: Mark Wielaard <mjw>
Status: CLOSED ERRATA QA Contact: Martin Cermak <mcermak>
Severity: high Docs Contact:
Priority: high    
Version: 6.6CC: alanm, bhubbard, drepper, mbenitez, mcermak, mikem, mjw, rousseau, xdmoon
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: elfutils-0.152-2.el6 Doc Type: Bug Fix
Doc Text:
Cause: eu-readelf was unable to read (some) 64-bit (s390x) ar archive files because it didn't supported the special entry /SYM64/ Consequence: eu-readelf would report "not a valid ELF file". Fix: Support for reading ar archives that contain special /SYM64/ entries has been added. Result: eu-readelf will properly read 64-bit ar archives.
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-10-14 06:42:28 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1023566, 1054486    

Description Ed Santiago 2014-01-30 21:15:55 UTC
eu-readelf 0.152 is unable to read (some) 64-bit s390x archives:

   not a valid ELF file

This blocks internal testing.

The fix is, I believe, commit e1873141a517738d8c50923e40525bb2ae6db68a.

Comment 2 Mark Wielaard 2014-01-30 21:54:21 UTC
This was fedora bug #843019 for which Petr wrote a fix which was accepted upstream and part of elfutils 0.155 (indeed the commit mentioned in the description). He also wrote a backport against the fedora elfutils package elfutils-0.154-sym64.patch

Comment 15 errata-xmlrpc 2014-10-14 06:42:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1472.html