Bug 1062929

Summary: [RFE] upgrade rhevm-dwh to 3.4.0
Product: Red Hat Enterprise Virtualization Manager Reporter: Alon Bar-Lev <alonbl>
Component: ovirt-engine-dwhAssignee: Yaniv Lavi <ylavi>
Status: CLOSED ERRATA QA Contact: Barak Dagan <bdagan>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 3.4.0CC: aberezin, acathrow, alonbl, gklein, iheim, lbopf, pstehlik, Rhev-m-bugs, sbonazzo, yeylon, ylavi
Target Milestone: ---Keywords: FutureFeature
Target Release: 3.4.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: infra
Fixed In Version: Doc Type: Enhancement
Doc Text:
rhevm-dwh build has been upgraded for Red Hat Enterprise Virtualization 3.4.
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-06-09 15:18:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Infra RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1078909, 1142926    

Description Alon Bar-Lev 2014-02-08 20:35:02 UTC
Until now rhevm-dwh was built using maven so at brew mead was used.

In 3.4 we ported build system to ant, so standard brew build can be used.

We need dist-git created for rhevm-dwh to enable management of downstream packaging.

Comment 1 Alon Bar-Lev 2014-02-14 21:02:59 UTC
dist-git was created, modifying subject.

Comment 12 Barak Dagan 2014-03-27 13:55:08 UTC
Verified on av5:
(rhevm-dwh-3.4.0-4.el6ev.src.rpm, noarch)


http://download.devel.redhat.com/brewroot/work/tasks/8817/7248817/build.log:


ENTER do(['bash', '--login', '-c', 'rpmbuild -bb --target noarch --nodeps builddir/build/SPECS/ovirt-engine-dwh.spec'], False, '/var/lib/mock/rhevm-3.4-rhel-6-build-2128938-857849/root/', None, 86400, True, 0, 250, 102, None, logger=<mock.trace_decorator.getLog object at 0x178bdc50>)

....

+ make -j1 BUILD_VALIDATION=0 PACKAGE_NAME=rhevm-dwh RPM_VERSION=3.4.0 RPM_RELEASE=4.el6ev LOCALSTATE_DIR=/var PREFIX=/usr SYSCONF_DIR=/etc BIN_DIR=/usr/bin DATAROOT_DIR=/usr/share MAN_DIR=/usr/share/man DOC_DIR=/usr/share/doc PYTHON=/usr/bin/python PYTHON_DIR=/usr/lib/python2.6/site-packages JAVA_DIR=/usr/share/java PKG_USER=ovirt PKG_GROUP=ovirt

Is this answers the question ?

Comment 13 Alon Bar-Lev 2014-03-27 15:18:49 UTC
(In reply to Barak Dagan from comment #12)
> Verified on av5:
> (rhevm-dwh-3.4.0-4.el6ev.src.rpm, noarch)
> 
> 
> http://download.devel.redhat.com/brewroot/work/tasks/8817/7248817/build.log:
> 
> 
> ENTER do(['bash', '--login', '-c', 'rpmbuild -bb --target noarch --nodeps
> builddir/build/SPECS/ovirt-engine-dwh.spec'], False,
> '/var/lib/mock/rhevm-3.4-rhel-6-build-2128938-857849/root/', None, 86400,
> True, 0, 250, 102, None, logger=<mock.trace_decorator.getLog object at
> 0x178bdc50>)
> 
> ....
> 
> + make -j1 BUILD_VALIDATION=0 PACKAGE_NAME=rhevm-dwh RPM_VERSION=3.4.0
> RPM_RELEASE=4.el6ev LOCALSTATE_DIR=/var PREFIX=/usr SYSCONF_DIR=/etc
> BIN_DIR=/usr/bin DATAROOT_DIR=/usr/share MAN_DIR=/usr/share/man
> DOC_DIR=/usr/share/doc PYTHON=/usr/bin/python
> PYTHON_DIR=/usr/lib/python2.6/site-packages JAVA_DIR=/usr/share/java
> PKG_USER=ovirt PKG_GROUP=ovirt
> 
> Is this answers the question ?

I am unsure what the question is.

Comment 14 Barak Dagan 2014-03-27 16:17:42 UTC
The question is how to verify that this BZ is verified.

Comment 15 Alon Bar-Lev 2014-03-27 16:20:13 UTC
You got rpms...

Comment 16 errata-xmlrpc 2014-06-09 15:18:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0601.html