Bug 1066409

Summary: [vdsm] storage domain is reported as 'active' by host, even though its link under /rhev/data-center/SPUUID/ is missing
Product: Red Hat Enterprise Virtualization Manager Reporter: rhev-integ
Component: vdsmAssignee: Nir Soffer <nsoffer>
Status: CLOSED ERRATA QA Contact: Aharon Canan <acanan>
Severity: high Docs Contact:
Priority: unspecified    
Version: 3.3.0CC: adahms, amureini, bazulay, dron, eedri, gklein, iheim, lpeer, obasan, scohen, vvyazmin, yeylon
Target Milestone: ---Keywords: ZStream
Target Release: 3.3.3Flags: amureini: Triaged+
Hardware: x86_64   
OS: Unspecified   
Whiteboard: storage
Fixed In Version: vdsm-4.13.2-0.14.el6ev Doc Type: Bug Fix
Doc Text:
Previously, VDSM would report that a storage domain was active even although a link for that storage domain was not present in the /rhev/data-center/SPUUID directory. This would occur when the host was in a non-operational state and was able to connect to the storage pool but was not able to connect to any storage domains. Now, the logic for refreshing storage domain links has been revised so that those links will be created correctly for storage domains even under these circumstances.
Story Points: ---
Clone Of: 1026697 Environment:
Last Closed: 2014-05-27 08:57:22 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Storage RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1026697    
Bug Blocks:    

Comment 2 Aharon Canan 2014-05-07 14:26:01 UTC
verified using is36

Verification steps:
1) Created a new shared DC with 2 host, created master domain, 1 host took SPM
2) Created second domain located on a different storage server
3) Blocked connectivity from HSM host to the non-master domain, host became non-operational, both domains remained 'active'.
While one of the pool's domain is unreachable to HSM host and it was non-operational, links of the 2nd domain under  /rhev/data-center/<pool-uuid>/ has disappeared.
4) Resumed connectivity from HSM host to non-master domain's storage server, host became 'up' and links were created again:

Comment 4 errata-xmlrpc 2014-05-27 08:57:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0548.html