Bug 1067669

Summary: Dracut must include kernel modules referencing symbol "blk_mq_init_queue" just like those referencing symbol "blk_init_queue"
Product: [Fedora] Fedora Reporter: Thorsten Kohfeldt <thorsten.kohfeldt>
Component: dracutAssignee: dracut-maint-list
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 20CC: dracut-maint-list, jonathan, toracat
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: dracut-037-10.git20140402.fc20 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1103455 (view as bug list) Environment:
Last Closed: 2014-04-06 02:37:41 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1103455    

Description Thorsten Kohfeldt 2014-02-20 20:14:13 UTC
Description of problem:

Dracut identifies kernel modules for block devices in
90kernel-modules/installkernel by a list of symbols.
One of the symbols is "blk_init_queue", which in the past lead to the inclusion of virtio_blk.ko for vm guests.
In kernel 3.13 virtio_blk calls the new function blk_mq_init_queue rather than blk_init_queue and thus the symbol match fails and virtio_blk is not included any more.

That way vm guests configured vor virtio_blk fail to boot kernel 3.13 unless virtio_blk is included for other reasons.

Please add symbol "blk_mq_init_queue" to the list of symbols next to "blk_init_queue" in 90kernel-modules/installkernel.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Fix suggested within above description.

Comment 1 Akemi Yagi 2014-02-21 08:03:27 UTC
I was having a boot problem on my KVM guest that uses virtio (host=RHEL 6.5 and guest=CentOS 6.5, kernel 3.13). This bug report explains the cause quite well. I created initramfs with a '--add-drivers virtio_blk' option and the kernel booted just fine.

Comment 2 Fedora Update System 2014-04-02 08:57:28 UTC
dracut-037-10.git20140402.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dracut-037-10.git20140402.fc20

Comment 3 Fedora Update System 2014-04-03 04:03:52 UTC
Package dracut-037-10.git20140402.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dracut-037-10.git20140402.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-4704/dracut-037-10.git20140402.fc20
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2014-04-06 02:37:41 UTC
dracut-037-10.git20140402.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.