Bug 1070447

Summary: rlm_sql group management broken in freeradius 3.0.1
Product: [Fedora] Fedora Reporter: Thomas Bartschies <tom>
Component: freeradiusAssignee: Nikolai Kondrashov <nikolai.kondrashov>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 20CC: jdennis, lemenkov, nikolai.kondrashov
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: freeradius-3.0.3-2.fc20 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-05-30 07:29:52 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Patch with described upstream fixes for the problem none

Description Thomas Bartschies 2014-02-26 21:00:34 UTC
Description of problem:
rlm_sql a known bug which is already fixed in upstream git
radgroupcheck and radgroupreply are never used
count of group membership fails

Version-Release number of selected component (if applicable):
3.0.1-2

Please apply upstream change 
Count number of retrieved groups 
git commit 6cec01dca2896b2500180a493b40886d3d5a4a3c

Comment 2 Thomas Bartschies 2014-03-11 19:38:13 UTC
Created attachment 873220 [details]
Patch with described upstream fixes for the problem

I've made a patch from the fixes in the upstream freeradius git.
Please apply them to the fedora package.
Without them the SQL group assigment is completely broken.

Comment 3 Fedora Update System 2014-05-07 18:32:57 UTC
freeradius-3.0.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/freeradius-3.0.2-1.fc20

Comment 4 Fedora Update System 2014-05-08 10:05:10 UTC
Package freeradius-3.0.2-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing freeradius-3.0.2-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-6089/freeradius-3.0.2-1.fc20
then log in and leave karma (feedback).

Comment 5 Thomas Bartschies 2014-05-19 17:47:47 UTC
I've tested freeradius version 3.0.2 from the f20 testing repo.
My issue is fixed.
But new issues were raised.

Someone ran a configuration reformatter on nearly all standard configuration
files. My problem arised specifically with the queries.conf file for mysql.

Some multiline options were commented only partially. The server misinterpretes
these queries and therefore the user and group sql queries won't work at all.

This new issue is mostly fixed in the new 3.0.3 release. This version is already
available. 

Please make a new build with version 3.0.3 available. 3.0.2 is broken in my opinion.

Comment 6 Nikolai Kondrashov 2014-05-19 18:01:12 UTC
Thank you for the report, Thomas.

I'll pull out the 3.0.2 update and will start working on 3.0.3.
However, preparing 3.0.3 release might take some time as there seem to be some important issues fixed post-release, which I'll need to accomodate.

Comment 7 Fedora Update System 2014-05-24 17:18:25 UTC
freeradius-3.0.3-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/freeradius-3.0.3-1.fc20

Comment 8 Fedora Update System 2014-05-25 23:29:11 UTC
Package freeradius-3.0.3-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing freeradius-3.0.3-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-6698/freeradius-3.0.3-1.fc20
then log in and leave karma (feedback).

Comment 9 Thomas Bartschies 2014-05-30 07:29:52 UTC
I've updated to freeradius-3.0.3-1.fc20.
This release finally works for me.

Thank you very much.

Comment 10 Fedora Update System 2014-06-16 23:27:48 UTC
freeradius-3.0.3-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.