Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.

Bug 107332

Summary: get the following error while exec'ing. unexpected PLT reloc type 0x00
Product: Red Hat Enterprise Linux 2.1 Reporter: Shailesh Phansalkar <shailesh_phansalkar>
Component: glibcAssignee: Jakub Jelinek <jakub>
Status: CLOSED NOTABUG QA Contact: Brian Brock <bbrock>
Severity: high Docs Contact:
Priority: high    
Version: 2.1CC: drepper, fweimer
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-09-28 04:15:21 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Shailesh Phansalkar 2003-10-16 19:20:58 EDT
Description of problem:

Get this error message while exec'ing my application and exec fails.
error while loading shared libraries: unexpected PLT reloc type 0x00

I get this only when I compile the app using -g and not when I use any 
optimization flags like +O2.


Version-Release number of selected component (if applicable):
glibc-2.2.4-32.8
gcc-2.96-118.7.2
2.4.9-e.27smp #1 SMP 

How reproducible:

happens every time.


Steps to Reproduce:
1. Exec the application.
2.
3.
    
Actual results:


Expected results:


Additional info:
Comment 1 Ulrich Drepper 2004-09-28 04:15:21 EDT
This means your binary is not build correctly.  In the relocation
section containing the PLT relocations you have an entry encoded with
0 instead of R_386_JMP_SLOT.  This is a bug of the linker.  If you can
reproduce this with recent AS2.1 versions with all updates, file a new
bug against binutils and include the output of readelf -r BINARY and
the object files used (or a recipe to produce them).

I'm closing the bug since it's no glibc issue at all.