Bug 1076802

Summary: udunits2 bundles expat (partially)
Product: [Fedora] Fedora Reporter: Ville Skytt√§ <ville.skytta>
Component: udunits2Assignee: Tom "spot" Callaway <tcallawa>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: orion, tcallawa
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: udunits2-2.2.12-1.fc21 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-06-03 12:19:06 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 182235, 504493    

Description Ville Skyttä 2014-03-15 05:08:56 EDT
https://fedoraproject.org/wiki/Packaging:Treatment_Of_Bundled_Libraries

Even though udunits2 links with system expat, it still bundles expat and ends up using some of the bundled expat files; that mismatch is something that will most likely cause problems at some point and should be fixed.

$ rpm -qlp http://kojipkgs.fedoraproject.org//packages/udunits2/2.1.24/5.fc20/x86_64/udunits2-debuginfo-2.1.24-5.fc20.x86_64.rpm | grep /expat
/usr/src/debug/udunits-2.1.24/expat
/usr/src/debug/udunits-2.1.24/expat/expat.h
/usr/src/debug/udunits-2.1.24/expat/expat_external.h
Comment 1 Orion Poplawski 2014-04-24 00:55:18 EDT
So, I'm looking to update to 2.2.11 which does drop bundling expat completely.  However, it looks like it gets a new license:

Copyright 2014 University Corporation for Atmospheric Research and contributors.
All rights reserved.

This software was developed by the Unidata Program Center of the
University Corporation for Atmospheric Research (UCAR)
<http://www.unidata.ucar.edu>.

Redistribution and use in source and binary forms, with or without modification,
are permitted provided that the following conditions are met:

   1) Redistributions of source code must retain the above copyright notice,
      this list of conditions and the following disclaimer.
   2) Redistributions in binary form must reproduce the above copyright notice,
      this list of conditions and the following disclaimer in the documentation
      and/or other materials provided with the distribution.
   3) Neither the names of the development group, the copyright holders, nor the
      names of contributors may be used to endorse or promote products derived
      from this software without specific prior written permission.
   4) This license shall terminate automatically and you may no longer exercise
      any of the rights granted to you by this license as of the date you
      commence an action, including a cross-claim or counterclaim, against
      the copyright holders or any contributor alleging that this software
      infringes a patent. This termination provision shall not apply for an
      action alleging patent infringement by combinations of this software with
      other software or hardware.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS
FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE CONTRIBUTORS
OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS WITH THE SOFTWARE.
---
which I don't recognize.  Spot, can you tell me what this is?  Thanks.
Comment 2 Orion Poplawski 2014-06-03 12:19:06 EDT
I've checked this in and built, but the license field is probably wrong.